Nissan XTerra Forum banner

1 - 17 of 17 Posts

·
Premium Member
Joined
·
488 Posts
Discussion Starter #1
Is there anyone left on this board who purchased new an original fully loaded 2000 4x4 with the factory sunroof?

Just curious.

I just got back from Virginia, drove up there to dig my sister out of 3 feet of snow. Xterra is still running like new.

Here is the crazy thing, All of the engine parts and accessories, CV joints, you name it, still work and have never failed. Starting to worry about my alternator though, at idle the bearing kicks a little but still charges. Other than a timing belt job/water pump job I did myself; the tires, brake pads and windshields are all that have failed. Original rotors still look newish.

Probably should replace the 16 year old radiator, looks new on the inside but I don't trust that plastic to support section anymore.

Did I purchase the least lemon Xterra ever made or what?;)
 

·
Premium Member
Joined
·
488 Posts
Discussion Starter #2 (Edited)
Thanks for the link xtacular.
[ame]http://www.amazon.com/TYC-2409-Aluminum-Replacement-Radiator/dp/B000IYNU3M/ref=sr_1_1?ie=UTF8&qid=1454749968&sr=8-1&keywords=2000+xterra+tyc+radiator[/ame]
One new double core TYC radiator ordered. I can quit worrying about a hose mount splitting off my 16 yr old rad, was seriously something I was expecting to happen.
92 bucks, what a deal. Must not be much interest in these old parts anymore.
 

·
Registered
Joined
·
2,004 Posts
i'm 2nd owner of my 2000. Still going fairly well at 150k. Needs me to track down the coolant leak and possibly a rear main or oil pan leak but its pretty minor. Think i'll tackle it if i do the lock group buy.
 

·
Premium Member
Joined
·
488 Posts
Discussion Starter #4 (Edited)
i'm 2nd owner of my 2000. Still going fairly well at 150k. Needs me to track down the coolant leak and possibly a rear main or oil pan leak but its pretty minor. Think i'll tackle it if i do the lock group buy.
I thought my rear main/pan was bad, turns out it was the passenger side valve cover seal and gaskets. Hopefully it isn't your driver side cover. You can still reach and snug the bolts up with a long phillips.
It also didn't help that over the years I could not stop myself for putting over 4 quarts of oil. The oil pan is supposed to hold like one cup of oil.
When I pulled the passenger side valve cover, the inside valve area was gold in color. Apparently I change my oil too much but that is not a bad thing.
 

·
Registered
Joined
·
44 Posts
Yes, I have one with a sunroof also. Didn't know that was an option, I thought they all had them. I am not the original owner, however my parents were. Inherited it for college and have had it ever since.

Going strong with 205,000 miles currently. Have done the timing belt twice now. Only failures were a distributor and recently replaced the original radiator. Has been a great truck.
 

·
Premium Member
Joined
·
488 Posts
Discussion Starter #6
Window sticker, they kept the side sticker with the jacked up price.
 

Attachments

·
Registered
Joined
·
1,214 Posts
I bought mine off my brother. He was the original owner. Very rare for a manufacturer to have a first year of a brand new model do so well. See so many first model year vehicles that need alot of bugs worked out of them.
 

·
Premium Member
Joined
·
488 Posts
Discussion Starter #8
Virginia last week, an area near rt 7 and 15 that received 3 feet of snow
 

Attachments

·
Premium Member
Joined
·
488 Posts
Discussion Starter #9
First road opening. Plow only made a one lane half scrape
 

Attachments

·
Registered
Joined
·
384 Posts
I can very much relate to Bwest. My parents bought this truck back in 2004 with only 48,000 miles on it. Mine is a 2001. It now has 121k miles in which 11,000 of those miles are from me. Only been driving for a year and two months now. So far had to replace fuel sending unit, distributor and the clutch. it's been great even though there are way funner cars to drive out there.
 

·
Registered
Joined
·
73 Posts
Nice. I have the OG sticker on mine, but at a less inflated price. Hahaha
 

·
Premium Member
Joined
·
488 Posts
Discussion Starter #14
So far had to replace fuel sending unit
I got the recall notice for the sending unit, ignored it, still works like new. The only other recall had to do with the shifter, ignored that also, shifter is fine.
 

·
Premium Member
Joined
·
488 Posts
Discussion Starter #15

 

·
Registered
Joined
·
73 Posts
nice looking unit. i like it.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
488 Posts
Discussion Starter #17 (Edited)
Yes, I have one with a sunroof also. Didn't know that was an option, I thought they all had them. I am not the original owner, however my parents were. Inherited it for college and have had it ever since.

Going strong with 205,000 miles currently. Have done the timing belt twice now. Only failures were a distributor and recently replaced the original radiator. Has been a great truck.
Family truck, good as being an original owner.
I've only seen 3 or 4 2000 X's with sunroofs on the road in all these years.
Does your X have the 6 disk CD changer in the back? LOL
 
1 - 17 of 17 Posts
Top