Nissan XTerra Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Ok noise question time everyone????....so my 03 x w/4x4 automatic question one. She seems to make a vibrating sound when accelerating and then the sound stop once I get to like 25ish mph, second question anyone else ever have a kind little touch of nails on a chalk board sound along the belts area and only really hear it in drive and reverse?
 

Attachments

·
Registered
2003 SE 4x4 V6 100k miles
Joined
·
398 Posts
The belt noise sounds like it could just be a worn out belt or a Pulley, but it’s only happening under load, so I’m not totally sure. Has the timing belt been changed on time?
I’m not really sure what a vibrating sound is, is there a vibrating feeling accompanying it? How is alignment and tire wear?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
Timing belt went out at 99,000 got it with 97 and now currently have 144 but the only things that haven't been changed along the belts area is my alternator, ac compressor, and their belts, but the vibrating sound is also felt through the gas pedal, granted she also has a hesitation to shift though as well but no leaks except for this
 

Attachments

·
Registered
Joined
·
17 Posts
Discussion Starter #4
Timing belt went out at 99,000 got it with 97 and now currently have 144 but the only things that haven't been changed along the belts area is my alternator, ac compressor, and their belts, but the vibrating sound is also felt through the gas pedal, granted she also has a hesitation to shift though as well but no leaks except for this
But the alternator works as does the AC and the belts still seem fairly good, also feeling alot of heat on my legs while driving??? I just wanna fix my x so I can start doing more fun removal and install stuff lol
 

·
Registered
2003 SE 4x4 V6 100k miles
Joined
·
398 Posts
Now this isn’t be said with any experience or real understanding of this, but the transmission could be an issue. Have you changed the fluid? The transmission is to the right of your legs and below, and if the fluids is old and crapped out it would cause the hesitation, even the vibrations, and is potentially heating up more rapidly than it would if it were a clean fluid. Very easy to do, either drain about 5 quarts through the bolt and replace the same amount you drained, or drop the whole pan and replace the filter as well as all of the fluid that comes out
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
Now this isn’t be said with any experience or real understanding of this, but the transmission could be an issue. Have you changed the fluid? The transmission is to the right of your legs and below, and if the fluids is old and crapped out it would cause the hesitation, even the vibrations, and is potentially heating up more rapidly than it would if it were a clean fluid. Very easy to do, either drain about 5 quarts through the bolt and replace the same amount you drained, or drop the whole pan and replace the filter as well as all of the fluid that comes out
Already replaced the filter and what ever amount of fluid that came out but didn't do a flush and that was about 6 months ago
 

·
Registered
Joined
·
17 Posts
Discussion Starter #7
Already replaced the filter and what ever amount of fluid that came out but didn't do a flush and that was about 6 months ago
I am about to get my transmission taking out and rebuilt here soon with this stimulus lol but hey the x needs the work....she is an 03 and I think I'm the only one out of three owners that have really gotten in the big work for her
 

·
Registered
2003 SE 4x4 V6 100k miles
Joined
·
398 Posts
Before you do anything too big, consider sensors such as the MAF, they can cause shifting issues, and play around with all of the steering and drivetrain components, check the u joints on the driveshaft and all the bushings, it’s tough to diagnose those things but hopefully you don’t need to spend too much on it!
 

·
Registered
Joined
·
17 Posts
Discussion Starter #9
Before you do anything too big, consider sensors such as the MAF, they can cause shifting issues, and play around with all of the steering and drivetrain components, check the u joints on the driveshaft and all the bushings, it’s tough to diagnose those things but hopefully you don’t need to spend too much on it!
Well no codes pop up and I have all the front suspension stuff just waiting to put them on but also was driving for quite awhile and also on the highway always in overdrive(auto when u start the truck) and about some months after I did the transmission filter the O/D off button kept flicking on and off and the x was jerking a little bit as I know u feel the difference when u press it but no I just drive always with the button on
 

·
Registered
Joined
·
17 Posts
Discussion Starter #10
Well no codes pop up and I have all the front suspension stuff just waiting to put them on but also was driving for quite awhile and also on the highway always in overdrive(auto when u start the truck) and about some months after I did the transmission filter the O/D off button kept flicking on and off and the x was jerking a little bit as I know u feel the difference when u press it but no I just drive always with the button on
Also starting driving strictly with the button on after when I let off the gas pedal and then step back on it I would sometimes hear but always feel through the pedal some sort of like clanking metal sound like something was trying to catch up???
 

·
Registered
Joined
·
3,183 Posts
But do not feel the clanking metal so much with the button on. Only when it's off do I hear and feel
you say your feeling heat under the truck in the leg area while driving? check your exhaust heat shieldsand the vibration is only while on the gas and stopws when you let off? if so check u joints on drive shaft and cv axle boots
 

·
Registered
Joined
·
17 Posts
Discussion Starter #13
you say your feeling heat under the truck in the leg area while driving? check your exhaust heat shieldsand the vibration is only while on the gas and stopws when you let off? if so check u joints on drive shaft and cv axle boots
it seems like the vibrating sound is only when she's trying to have some get up whether it be speeding up on the highway or coming from a red light and the clanking noise is only heard when I let up off the gas and then press back on the gas again
 

·
Registered
Joined
·
77 Posts
You might have a cracked exhaust manifold that is causing your feet to feel warm. In addition, any small holes/leaks from the exhaust manifold may more than likely cause odd noises. Imagine air under high pressure escaping through a small hole (think whistle) the noise you are hearing may be related to that. Might be worth looking at.
 

·
Registered
Joined
·
3,183 Posts
You might have a cracked exhaust manifold that is causing your feet to feel warm. In addition, any small holes/leaks from the exhaust manifold may more than likely cause odd noises. Imagine air under high pressure escaping through a small hole (think whistle) the noise you are hearing may be related to that. Might be worth looking at.
this is alos another possibility somewhat common on the 3.3 to get cracks in the exhuast manis. both the 3.3s i had had some but i just ignored them and wrapped some heat sheilding on the underside of the truck under my feet/seat to keep anything from happening
 
1 - 16 of 16 Posts
Top