Nissan XTerra Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Ive had this noise which sounds like a metal rod banging around hitting things but cannot find it. Its coming from the drivers side and seems to be from around the front tire area. I just had new tierod, balljoint, shocks installed to try to eliminate the noise but it didnt change a thing. It seemed to occur more often after i had lowered the driver side torsion bar to level out the front. I checked all the bolts i could see and everything is tight. If anyone has suggestions on what to lool for plz let me know. Here is a a link to a vid i took today

http://youtu.be/N1zOBijI-HY
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
I hope its not a loose bolt cuz ill probly never find it. Id think it would be a suspension component if it became alot more noticeable after messing with the torsion
 

·
Registered
Joined
·
18 Posts
I had a similar problem last winter. My exhaust pipe broke from the hanger weld on the top of the exhaust. I couldn't see it so i started banging on things with a rubber mallet. It started making the noise with bumps and then progressed with idle.

Good luck
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
So i did wat you said rfe, i started banging on things with a mallet. I started on the skid plate then onto the lca. Thats where i found the same noise from hitting bumps. So i kept hitting in and through 1 of the 2 small holes underneath the lca i saw something move and it seems to be a washer, possibly a nut at one point but i didnt see that one. I couldnt get it out cuz it was bigger than the hole. Im gonna try to get something with a magnet tip inside there some how and if that fails i might have to just trap it in with some spray foam
 
1 - 10 of 10 Posts
Top