Nissan XTerra Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
392 Posts
Discussion Starter · #1 · (Edited)
Hey fellas! Looking for a little help with this headache. The usual culprits have been replaced.... but that is not to say they didn't go bad again...

It's a 2000 Frontier V6 4x4 CC with 104k miles. It just randomly dies going down the road. Sometimes it restarts. Sometimes it doesn't. Sometimes I just get a small blip (loss of spark or fuel) when going down the road then it's fine again. Sure seems like a loose connection somewhere to me.

Fall 2014 - Fuel Sending Unit; Had similar problems a little over a year ago and I replaced this at ~90k miles. The stock one was corroded and the fuel pump wasn't getting power. Got the part from Nissan directly. Truck ran great for a year then started having same issues in fall of 2015. I am thinking this couldn't have gone bad again in only a year, but who knows?

December 2015 - Distributor; I replaced it with one from Vato Zone. Had the same problems that day. Returned that and replaced with one from Napa (New - house brand - supposedly made by Altrom - which is supposedly comparable to OEM) This seemed to fix it for a little while. At the same time I did the timing belt, spark plugs, wires, valve cover gaskets, a bunch of suspension work, etc. so I had the harness off. Did I knock something loose? I feel like I have checked it up and down.... doesn't seem that way.

January 2015 Bad Wire?; Same issues. Wiggling the harness into the distributor seemed to have an effect on restarting so I pulled the harness apart from the dist to the main and found a small cut on the casing of one of the ground wires. The wire was not damaged, just casing. Fixed that with a double layer of shrink tube and it ran fine again for a couple months.

April 2015 FUCK; Now it is doing it again. This god damn truck is so unreliable it makes me want to puke. I know it has to be something stupid...

Any ideas? I gave up and took it to a shop but they are telling me they want to replace the ECM or wiring harness for thousands of dollars. It seems very unlikely that this is actually the issue. I am having them replace the distributor again (free part with Napa warranty). So far I am out about $230 for labor (diagnosis and 1/2 hour installing dist). They are putting it in on Monday so I won't know until then whether they think it is fixed.

If this doesn't fix it what would you guys look for next? (aside from sending it to the crusher cutting my losses and putting a down payment on a 4x4 Sprinter Van)

Seth
 

·
Registered
Joined
·
36 Posts
After swapping my 01 X with a JDM motor a couple weeks ago the exact same thing is happening to me. My scanner picked up the code of PO1101 which is the MAF sensor. I am changing it out Monday, i hope that will do the trick. Hope this helps you too.
 

·
Registered
Joined
·
392 Posts
Discussion Starter · #4 ·
Okay. Since I last posted I have put in TWO more distributors. Runs fine for a little while then this happens again. I am on distributor #5 since this all began. They all do seem to get progressively worse until it barely runs. A new distributor seems to make it run fine for a few weeks, though I do not drive it that often.

I also had bad cats. I removed the front cats, added rear cats, added headers, CEL eliminators, and a full new exhaust. This took care of the other problems I was having (mainly loss of power) but doesn't seem to be related to the loss of ignition. I finally drove it with no CEL for about half a day until it started up with the ignition problem AGAIN.

So today... I ordered some MAF cleaner (mine doesn't look dirty), a new knock sensor (cause WTF why not) and ANOTHER distributor... this will be the SIXTH distributor in less than 2,000 miles. This time a re-manufactured one from Nissan.

Any other suggestions? I don't trust this truck to make it to the grocery store... this has been going on now for over 6 months. Would my clogged cats somehow have been causing the distributors to go bad? Even the shop I took it to said BAD DIST...
 
1 - 4 of 4 Posts
Top