Nissan XTerra Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hi everyone,

I had some questions about my automatic transmission on my 4x4 2002 Nissan Xterra XE v6. Sometimes when i shift from neutral to drove, or from park to reverse, it takes a few moments to engage.

When i am driving down the road, when i am moving between 35 and about 40 mph and i take my foot off of the gas, then back on the gas, my car jerks or feels like a clunking feeling. Someone told me it may be transmission mounts that cause the clunk because of the torque, but what causes a delayed shifting?
Could my auto trans use a service with new fluid and filter?

Any help or advice is very much appreciated.
Thanks!
 

·
Registered
Joined
·
138 Posts
That happen to my 01 Frontier. Does it only happen after driving a while? I did the pan thing and found nothing. Decided to install a B&M trans cooler and flush the trans to see if it would help. It did, it's been a little over a year and still going good.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
That happen to my 01 Frontier. Does it only happen after driving a while? I did the pan thing and found nothing. Decided to install a B&M trans cooler and flush the trans to see if it would help. It did, it's been a little over a year and still going good.
What did you pay for your transmission cooler? If you don't mind me asking. Would you say it is definitely worth it?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top