Nissan XTerra Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hoping someone might be able to help! When I am coming to a slow stop from approximately 40 MPH (almost always on a particular road) I hear a thud and it feels like something has shifted in the trunk and is banging up against the hatch (there is nothing in the trunk). I am typically driving by myself so I can't tell you much more about the sound or location other than what I described and it has happened maybe 8-9 times over the last year. It happened two days in a row last week, but not since. I've gone months without hearing anything.

I have a 2002, 4WD, automatic with 142,000 miles. We have done A LOT of repairs/maint in the last year and am hoping to get it in really good shape before it gets much colder. The last few things my husband is doing this weekend are changing front/rear differential fluids, and new stabilizer bar. In the last 6-9 months we have done:
4 new tires
new brakes (rotors, calipers, pads)
shocks
timing belt, water pump, thermostat, tentioners~etc.
starter
alternator
drive, ac, ps belts
changed transfer case fliud
spark plugs (ordered wires to switch out as well)

Last question...we have not been good about trans fluid maint. I've read people for and against high mileage flushes. We were thinking of just draining and adding a couple times over the next few weeks. The fluid is still pinkish, not brown and tranny so far is running well...I'd like to keep it that way. Any thoughts here??
 
1 - 1 of 1 Posts
Top