Nissan XTerra Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
384 Posts
Discussion Starter #1
ok so i changed the clutch on the xterra with a few weird things going on. First of all. My starter makes a low grinding noise when starting up. I must inform that i put a new flywheel in as i did the project. I noticed the flywheels look different on the teeth ever so slightly but everything else is the same. Also my clutch pedal is pretty soft now. The biting zone is about the same but it is pretty soft before i have the clutch pedal hitting the bite zone. Meaning from the floor to the bite zone. It works wonderfully now though other than that. Shifting is smooth and launches and shifts are just fine. PLZ help. 2001 nissan xterra 120k miles.
 

·
Registered
Joined
·
384 Posts
Discussion Starter #2
ok so i decided to post back up about this issue since i don't like leaving cliff hangers. The super soft clutch pedal was gone after 300 miles of driving. now it feels almost as hard as before. I think i know what the grinding noise is. It's not a grind but rather the starter is hitting against the spacer plate between the tranny and the engine. We had to cut a small piece off the plate to take off the rear main seal retainer. It may be slightly loose in there or crooked since it sounds like a thin piece of foil is being rubbed against. the rubbing sound is getting lower little by little so i guess everything is fine. I personally think the old clutch was mostly fine. This new one feels exactly like the old one except it doesn't violently shake on take offs and i can finally floor it. She also loves revving now. happy holidays.
 

·
Registered
Joined
·
808 Posts
Glad problem solved. Maybe there was some air that worked out. The starter may need a spacer. I had a similar problem after a motor swap (jammed on the starter). Solved it by making a spacer to bring the starter further away from the flywheel. Happy holidays back to you.
 
1 - 3 of 3 Posts
Top