Nissan XTerra Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
The other day I went to meet my girlfriend, cold morning, let car warm up like usual for 10-20min. I drove 14 miles and then it started to act like it wanted to stall on me. Then wouldn't let me drive at all. Cleaned MAF sensor, replaced fuel filter. Still shacking after driving Les then 5miles.
 

·
Sage Mentor/Moderator
Joined
·
12,216 Posts
The other day I went to meet my girlfriend, cold morning, let car warm up like usual for 10-20min.

I drove 14 miles and then it started to act like it wanted to stall on me.

Then wouldn't let me drive at all.

Cleaned MAF sensor, replaced fuel filter.

Still shacking after driving Les then 5miles.
OK, so if I hear you right,

1) you live too far from your GF?

>:D

2) After ~ 14 miles, it acted like it wanted to stall...meaning, it did a monologue about stalling, and how desirable that would be? It actually stalled? It hesitated? Symptoms? (Need a better diagnostic description)

3) It wouldn't let you drive at all? - The engine stopped, and would not restart? The engine was running, but you could not drive for another reason? (Again, need a better diagnostic description)

4) Cleaned MAF, hopefully, with MAF cleaner and not brake cleaner, etc..? Replaced fuel filter (Good)...

5) STILL shacking (Shaking?), after less than 5 miles, but, you never mentioned it shaking before...is that new, or, was that part of the "wanting to stall" or "not letting you drive"?

Did it NOT shake for the first few miles, and then START close to reaching 5 miles?

Is this the same thing as the above issues?

Have you already changed the timing belt? (What mileage?)

How old are the plugs, wires and distributor?

What did you clean the MAF with?

Is the bottom of the intake plenum (From air box to engine) cracked underneath where you can't see it?

Hows your alternator/battery?

Engine mounts?

That's a start at least, report back!

>:D
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
We live together, (meeting after work) yes shaking was part of the initial issue. Bought car off sis, so don't know wen timing was done. I've done regular tune ups about every 3,500- 5,000 miles. Distributor has not been changed as far as I know. Cap and rotor look fine. Yes I used MAF cleaner. Cleaned throttle body with TB cleaner.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
It was sputtering, shaking. Then not driving, starts up fine. Go to the end of road (3/4 mile) and starts sputtering and shaking.
 

·
Sage Mentor/Moderator
Joined
·
12,216 Posts
We live together, (meeting after work) yes shaking was part of the initial issue. Bought car off sis, so don't know wen timing was done. I've done regular tune ups about every 3,500- 5,000 miles. Distributor has not been changed as far as I know. Cap and rotor look fine. Yes I used MAF cleaner. Cleaned throttle body with TB cleaner.
LOL

OK, so, too close, not too far.

If the timing belt was never done, it was due at 105k miles...and, well, its an interference engine...so, bad things CAN happen if it goes on you.

They slip a tooth sometimes, messing up the timing w/o catastrophic failure, for example.

Shaking, was that still going on if you were parked and idling, or, only when moving?

Did it change in nature when you gave it gas, or let off and coasted?

It would helpt to know the way it shakes too, as in fore/aft, or, side to side, etc...if in time with rpm (More rpm = worse/faster shaking, etc?)
 

·
Registered
Joined
·
16 Posts
Discussion Starter #10
Like it wants to stall then when I come to stop it stalls and dies. Starts but its sputtering after warm up and driving
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
Timing belt was done about a year ago. Sis was good bout keeping on it. Yes it continues qith issue in idle and park after the drive down the road.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #12
When I give it gas it sputters. And then aggressively sputters/shake up and down in between 2500-3000rpms
 

·
Sage Mentor/Moderator
Joined
·
12,216 Posts
When I give it gas it sputters. And then aggressively sputters/shake up and down in between 2500-3000rpms
So, it not rocking side to side, or fore/aft...its going up/down?

Does the shaking get worse if the RPM is higher, or, is it limited to the 2,500 - 3,000 range?

Is the sputtering you mention different from the shaking you mentioned?

Sputters, typically, are fore/aft in nature, as you quickly go between a little power and none/too little, sort of going in fits and starts, etc...
 

·
Registered
Joined
·
16 Posts
Discussion Starter #14
The acceleration is how can I describe... (Popcorning) I didn't mean like jerking(sputtering) or like wen u get death wobble(shaking)... It's kinda like wen ur low on gas and its doing that sputtering. U know like not getting adequet fuel.
 

·
Registered
Joined
·
59 Posts
... U know like not getting adequet fuel.
I think you nailed it there.

FYI if it's an automatic I think there's a neutral rev limiter so it won't rev past a certain RPM unless its in gear anyway. Rev limiters usually work by cutting fuel so it would act pretty goofy/shake about if you're just holding the throttle open at idle.

Besides that, what you're describing sounds like a fuel pressure/delivery issue.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #16
When car is first started and wrmed up it revs up into the 4,500 just fine, the 2,500-3000 rpms is when its been driven less then a mile
 
1 - 17 of 17 Posts
Top