Nissan XTerra Forum banner
1 - 20 of 35 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
Wadup guys!
I have a quick question.

Alright so I been having a lot of starting problems. After letting my car sit for a few days the battery would die. I charged the battery cleaned the terminals and same problem.

I checked the terminals and only the right side was corroded and noticed it was slightly lifted. Like pressured made it pop up a little.

Also it has this weird random starting problem. The X would start fine and id stop at the store and when I go to start my car it would crank really slowly like it didnt want to start. Id turn my car off and try again and it would start up fine!!

So I just went and bought another battery! Starts up fine and I waited to see if the problem would occur still.

Last night i stopped for gas and when i tried to start it, it turned over even slower! It didnt even turn over the first time like usual. I waited a little while and thankfully it started. It turned over with ease. So weird.

The multi meter reads 12v and the battery is new so I doubt its the battery. When the car is running its at like 13.5v so im thinking the alternater is good. The only thing I can think of is the starter?

Anyone else have this problem? I hate how the problem is completely random so its hard to diagnose. Any feedback will be HIGHLYYYYY appreciated. Thanx!
 

Attachments

·
Registered
Joined
·
50 Posts
Discussion Starter · #4 ·
Ya there's a little. I had a bad oil leak from the valve cover but I temporarily fixed it by tightening the screws then degreasing the engine. So it probably is the starter? Should I replace it or take it out and clean it? Also where would you buy parts online from?

Thanx for the reply
 

·
Registered
Joined
·
444 Posts
X2 on the starter. I would fashion yourself a drip shield out of an aluminum can or sheet metal (thrift store cookie sheets work awesome and are more durable), but for sure replace that bad boy. ROCKAUTO.COM is my favorite online parts spot, or nissanpartsdeals.com. The oil probably soaked the brushes and that is why sometimes it cranks slowly.

Sent from my SM-N920V using Tapatalk
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #6 ·
Never thought of making my own shield! Lol might have to try that. Thanx for the advice. I appreciate it. I'm going to buy a starter from one of those recomended websites. Napas wanted like $180!
 

·
Premium Member
Joined
·
8,525 Posts
Ya there's a little. I had a bad oil leak from the valve cover but I temporarily fixed it by tightening the screws then degreasing the engine. So it probably is the starter? Should I replace it or take it out and clean it? Also where would you buy parts online from?

Thanx for the reply
Its toast if it has oil on it , its really easy to fix pass side valve cover . Tightening the screws will just make it leak more the gasket is broken ,make sure you get grommets with gasket.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #9 ·
Alright so today I went to check out the beach. Turned the car off for 15 minutes , got back in the car and tried to crank it. It turned even slower! And it didn't turn over. So I waited a few minutes and this time it wouldn't even crank at all! Nothing. Waited 15 minutes and tried again. This time it was trying to turn over but it was really weak. Checked the battery and it was fine. I ended up waiting longer and cleaned all the terminals with sandpaper. The cranking sounded a little stronger but didn't turn over. Waited a while, Tried again and it started. What a relief.

I'm definitely going to buy a starter and also the valve cover gasket. Hopefully I solve this problem. Weird how it's so random. I was out all day yesterday and stopped everywhere and it started just fine.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #13 ·
Alright so I just ordered the starter. Hoping this solves my problem.

I noticed that the X never has a problem starting when it's been sitting. Every time it gave me problems it was when I turned it off for a few minutes. Ex: stopping for gas.

My brother had a starting problem where, every time he turned off his car, he had to wait like half an hour to and hour before it would crank and turn over. Turned out to be his starter.

My plans are to degrease under the engine, wires , ect.
Replace starter
Replace valve gasket(no more oil dripping on starter)
And HOPEFULLY this solves the problem.

Really want to go camping this spring break. Hope this does the trick

Thanx
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #15 ·
I would also ensure the power wire to the starter is in good order while you're there

Darin
01 Xterra SE 4x4
PML, EFan, stock intake mod, shocks, a bunch of maintenance, and a tune up coming soon
Do I use a multi meter for that? I went down there last night and the wire and connector had oil all over it. The starter had some oil and a little inside as well.

I was thinking , maybe going down there with some degreaser and a water spray bottle and some rags and cleaning it. I would use a hose but I don't want to mess anything up.

How can I clean the inside of a connector? I'm assuming stay away from water right? Lol
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #19 ·
Here's the starter. I took it out last night. Canceled my Amazon order , they wanted like $40 bucks shipping since I live Hawaii. So I ended up going to oriellys and picking one up along with a valve cover gasket


Anyways this starter don't look too bad right? But I guess like deja said, any oil in the starter and its toast. Going to install the new starter today
 

Attachments

1 - 20 of 35 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top