Nissan XTerra Forum banner
21 - 30 of 30 Posts

·
Registered
2006 Nissan Xterra 4.0LV6 RWD Automatic
Joined
·
17 Posts
Discussion Starter · #24 ·
Wonder if you could get enough of a hydraulic lock to cause that shake from fuel building up in #1 cylinder from a faulty injector?
she is down at my mechanic now. they’re taking apart that upper part of my engine to do my spark plugs, spark plug tube seals, valve cover gaskets, and valve covers as well as they’re going to check on my fuel injectors! i’ll keep posting updates until she’s back running like normal.
 

·
Registered
2015 Xterra Pro-4X
Joined
·
1,968 Posts
she is down at my mechanic now. they’re taking apart that upper part of my engine to do my spark plugs, spark plug tube seals, valve cover gaskets, and valve covers as well as they’re going to check on my fuel injectors! i’ll keep posting updates until she’s back running like normal.
Under the knife! Hope they can control the bleeding....the green stuff that is.
 

·
Registered
2006 Nissan Xterra 4.0LV6 RWD Automatic
Joined
·
17 Posts
Discussion Starter · #26 ·
she is down at my mechanic now. they’re taking apart that upper part of my engine to do my spark plugs, spark plug tube seals, valve cover gaskets, and valve covers as well as they’re going to check on my fuel injectors! i’ll keep posting updates until she’s back running like normal.
she’s all taken apart. a singular bad coil on cylinder one. of course the hardest to get to
 

·
Registered
2006 Nissan Xterra 4.0LV6 RWD Automatic
Joined
·
17 Posts
Discussion Starter · #27 ·
View attachment 79787 she’s all taken apart. a singular bad coil on cylinder one. of course the hardest to get to
totally forgot to give a final update! coil on cylinder one died and was causing the misfire! Xandra is home and safe. Runs like new and i don’t even realize she’s idling now. We did the valve cover and gasket replacement as well and i got a new vacuum hose since one of mine was so cracked it was about to start leaking! Thank you all for the help and concern expressed for my Xterra!
 

·
Registered
2015 Xterra Pro-4X
Joined
·
1,968 Posts
totally forgot to give a final update! coil on cylinder one died and was causing the misfire! Xandra is home and safe. Runs like new and i don’t even realize she’s idling now. We did the valve cover and gasket replacement as well and i got a new vacuum hose since one of mine was so cracked it was about to start leaking! Thank you all for the help and concern expressed for my Xterra!
You are truly blessed! Thanks for following up.
 
21 - 30 of 30 Posts
Top