Nissan XTerra Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
I've searched through this forum and cant find an answer specific to my problem unfortunately. Hoping I can get some advice?
I drive a 2002 4x4 XE automatic.
When I accelerate hard there is a very distinct (and quite annoying) vibration mixed with a sort of sharp clinging/pinging noise coming from (I think) the front end. It ONLY happens when I accelerate hard, then goes away when I reach the desired speed or if I let off.
The u-joints are brand new, and I plan on doing a transmission service within the next 100 miles.
The spark plugs are new.
I checked the engine bay for obviously loose components but cannot find any.
Any ideas??
 

·
Registered
Joined
·
444 Posts
Friction plates in the tranny? How many miles ya got?

Darin
01 Xterra SE 4x4
COMING SOON:
Intake mod, timing belt, hoses, belts
Wish list:
PML, EFan conversion, shocks, 32" tires, and eventually UCA'S
 

·
Registered
Joined
·
787 Posts
I have a similar noise coming from the same location when I accelerate hard.

2004 SE 4x4 with almost 115,000 miles

Doesn't occur all the time. Usually, if not always, when I have the AC on I believe. I also experience a vibration every so often stopped at a light in Drive with the AC on.

Could be an AC compressor issue for me. Do you have any of that going on too?
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
Could be an AC compressor issue for me. Do you have any of that going on too?[/QUOTE]

No I don't... I don't use my AC since it doesn't even work. The vibration never seems to go away (I mean when accelerating hard). It does not seem to depend on any sort of electronic controlled variable.
 

·
Registered
Joined
·
444 Posts
If your AC isn't working, could it be the compressor? I mean if that is the reason your AC isn't working, that would be a definite possibility right there

Darin
01 Xterra SE 4x4
COMING SOON:
Intake mod, timing belt, hoses, belts
Wish list:
PML, EFan conversion, shocks, 32" tires, and eventually UCA'S
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #7 ·
If your AC isn't working, could it be the compressor? I mean if that is the reason your AC isn't working, that would be a definite possibility right there

Darin
01 Xterra SE 4x4
COMING SOON:
Intake mod, timing belt, hoses, belts
Wish list:
PML, EFan conversion, shocks, 32" tires, and eventually UCA'S
What I still don't understand is how a malfunctioning AC system would vibrate. And I don't have a clue where to start when it comes to fixing the issue. Recharge my AC? Replace the whole system or just the compressor?
 

·
Registered
Joined
·
444 Posts
Try taking the belt off...sometimes the clutch and/or bearing inside can start to go causing issues, or the tensioner could be at fault...take the belt off and see if it cures it, it is free and takes like 20 minutes tops

Darin
01 Xterra SE 4x4
COMING SOON:
Intake mod, timing belt, hoses, belts
Wish list:
PML, EFan conversion, shocks, 32" tires, and eventually UCA'S
 
1 - 8 of 8 Posts
Top