Nissan XTerra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I (my girlfriend) has a 2006 xterra, 4.0, a/t. Recently on a trip I noticed the ses light came on. scanned for codes when we got home, found p0171 lean bank 1 sensor 1. cleared the code and it ran a little strange since then. Finally it acted up enough at a higher RPM( merging into traffic )to throw a code p0300 & p0171 ses flashed at once. Things I have done

Replaced Air Filter
Cleaned MAF
Cleaned Throttle Body (And performed reset procedure)
Replaced Upper Intake Manifold Gaskets
Replaced Spark Plugs

It seems to start fine, high idle is ok then when it comes back down to regular idle it will run VERY rough.

Thinking potential vacuum leak? 02 sensor, EGR Valve? worst case scenario I was thinking cats...:|
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
Update: replaced PCV Valve, truck ran fine for 2 days.

Things done:
Cleaned MAF
Cleaned Throttle Body
Replaced Throttle body gasket
Replaced upper intake manifold gaskets
Replaced spark plugs
Replaced PCV Valve

Running rough, codes I have stored now are : p0300 random misfire and p0131 02 circuit low voltage bank 1 sensor 1

Checking for vacuum leaks today or tomorrow, assuming I will find something...
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Bad maf sensor maybe? Look inside the air filter housing. Animals love putting nests in there.
I don't think the MAF is bad... I may have to run a test or two? I'll see if I can find a spec. I pulled it out when I cleaned it and I cleaned it well with CRC MAF cleaner. Everything on the inside was clean and clear.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Update: Okay, so I replaced the 02 sensor because it had two voltage codes and a random misfire.
This problem is making me feel dumb... I'm going to try to read up on the code and what the other reading could signify.

Things done:
Cleaned MAF
Cleaned Throttle Body
Replaced Throttle body gasket
Replaced upper intake manifold gaskets
Replaced spark plugs
Replaced PCV Valve
Replaced 02 Sensor
Checked for vacuum leaks, found none at this time.

Running rough, codes I have stored now are : P2A00
Specifications for DTC:
MIL ON: P2A00
MIL Pending:p2A00
Fuel System 1 Closed Loop
Fuel System 2 Closed Loop
Calculated Load 13.7
ECT 92 Celsius
Short Term Fuel Trim Bank 1 15.6
Long Term Fuel Trim Bank 1 -10.2
Short Term Fuel Trim Bank 2 -0.8
Long Term Fuel Trim Bank 2 7.0
Engine RPM 1113
Vehicle Speed 64 mph
TPS 1.6%
 
1 - 5 of 5 Posts
Top