Nissan XTerra Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Hello!

Recently acquired my second Xterra. This time its a 2003 4wd 5spd, with 127k. Got it as a trade, planned to make it my daily for awhile. Nothing crazy like most of you, I just like Xterras, and this one seemed nice. Clean Carfax, but its got some wonky things going on that makes me think it wasn't taken care of as well as I would have liked. No maintenance records, so I don't know if the Timing belt was ever done, kind of bounces around on the road, clutch pedal is squeaky as hell, hood rubs the plastic cowl upon opening, and this 3000 rpm @65/67mph(+or- a mile or so) kinda sucks. I'll keep it for now, its just not a super friendly driver currently. Hope to learn a ton here, hope I don't wear you out with stupid questions.

My new X:




The old 2wd one that I loved (and was much more road friendly).
 

·
Registered
Joined
·
816 Posts
And we have every stupid answer you could ask for.
Welcome aboard.
 

·
Vendor
Joined
·
749 Posts
Hello and welcome to the club! Congrats on your purchase, looks great! Lots of very informed members on here with a wealth of information, so you've come to the right place. Please feel free to reach out to us if you have any questions at all, we are always happy to help!
 

·
Registered
Joined
·
384 Posts
welcome to the club. I have a 5 speed as well. The clutch squeaking to me is the car telling me she loves me. I doubt you could have made it that far with that timing belt. Mines at 110k was done for. A good way to check is by the cars launch. Is she hard to take off from a dead stop? If so then it might be going since thats what mine did before the timing belt job.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #9
No, takes off great from stop. That's really a symptom? Odd.
 
1 - 9 of 9 Posts
Top