Nissan XTerra Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Before all of this happened I had a engine light on for about 2 weeks and it went away, I'd say about 2 weeks later is when the first problem started to occur. I was driving home on a rainy night and the car started to jerk, I was going about 70 and it was subtly. There was a lot of rain on the road so I thought I was hydroplanning. I put it off to the side, couple of next days it starts to get bad. The car started to jerk violently. RPM's spike, acceleration was there but it was just spiking 2-3, 3-4(1000's) and so on. At first it was only when the vehicle was driven for a little bit (10-20minutes) but the last day it ran, it was shit from the get-go. Started it up and in idle it started to jump. Driving to school, one of my friends was behind me and said that blackish smoke was coming out of the exhaust (unburnt fuel?). Get to my parking spot and throw it in park and turn it off immediately. What I believe it to be exhaust smoke was coming out from the passenger side under the hood, under where the cruise control is. Went to school got out, called my dad. He told me to try and start driving it got about half way there and it died on a hill. It sounded like there was a small back fire. Lost all acceleration and car went dead. Ran a test and came back with a knock sensor (going to replace it), is this the problem or is there an underlying problem. Anything will help, year 2000, 139k miles, 2wd, 3.3L, v6, Auto, Not 4x4. The X is my baby, better than any eX girlfriend.

TL;DR
RPM spikes, at first when it was warmed up. Last time it was spiking right from the beginning. Acceleration there but barely. Engine test says Knock Sensor, don't think that's the only thing wrong.
 

·
Registered
Joined
·
2,004 Posts
Pull distributor cap and look for reddish brown dust. If so the bearing is shot and you need to replace it. there is a how to in the how to section.
 
1 - 2 of 2 Posts
Top