Nissan XTerra Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
on a 2000 xterra, I had the timing belt,tensioner, water pump, thermostat and all the belts replaced. after that I noticed it did not seem to idle exactly right when I was stopped by the break in gear, nothing bad just seemed a little off.

I recently got a check engine light(2 days ago), p 0300 p 0325, it said 4 codes it was just these codes duplicated. 300 is random misfire and 0325 is knock sensor, and that appears to be a major undertaking to replace, I heard it can be disconnected and relocated to an easier place. I just spent $550 for the last service. (i hear that is a good price) I really will have to scramble to come up with another $500 for this. any info is appreciated from anyone,
[email protected] in case I dont get the thread.
SP
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
thanks

Thanks for the reply Dennis,
I am hearing that it could just need plugs wires dist ect, basically a tune up, I do not know if it ever had one since they are required at such high miles,
I will let you know.
SP
 

·
Registered
Joined
·
10 Posts
I have the extact same problem. I have a 2000 X Se, I changed the plugs and wires last July. Then in August I did the timing belt kit, all belts, water pump, thermostat, tensioner pulley. Also did the cap and rotor on the distributor.

Idle RPM is around 700. I get the random misfires, and knock sensor errors. If you let it idle for more than a minute or two the check engine light will start flashing. But if you rev the engine it will go away.

It runs ok, but has a weird sound that seems to go away around 35 -40 MPH...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
So the distributor needs replaced??? How much does something like this cost??
The guy cleaned the throttle body and I added injection cleaner on a couple tanks of premium and it seemed to help quite a bit. I have not gotten a Engine light since all this has been done. Thanks,
SP
 

·
Registered
Joined
·
10 Posts
I checked the distributor when I changed the cap and rotor. I didn't notice any metal shavings and it seemed to turn ok. Is there anything besides the distributor that can cause these problems?
 

·
Registered
Joined
·
10 Posts
Yes I believe there was some black dust. Don't remember how much as I replaced the cap and rotor in August of last year. It has about 106000 miles on it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #12
Dejablue

Thanks for the information, I am glad someone as knowledgeable as you is here to help us novices out,
Stallion
 

·
Registered
Joined
·
46 Posts
on a 2000 xterra, I had the timing belt,tensioner, water pump, thermostat and all the belts replaced. after that I noticed it did not seem to idle exactly right when I was stopped by the break in gear, nothing bad just seemed a little off.

I recently got a check engine light(2 days ago), p 0300 p 0325, it said 4 codes it was just these codes duplicated. 300 is random misfire and 0325 is knock sensor, and that appears to be a major undertaking to replace, I heard it can be disconnected and relocated to an easier place. I just spent $550 for the last service. (i hear that is a good price) I really will have to scramble to come up with another $500 for this. any info is appreciated from anyone,
[email protected] in case I dont get the thread.
SP
I changed my KS as well and it was done a t a friend shop..cost me 800.00 with parts..a helluva job..
I used a jobber..and teh light did go away..for about a week or two,...then it was the 02 sensors...
There was a read I believe at XOC on how to replace the KS at the exterior area of the motor and it did look simple enough if you know your way around a motor etc..
I ll try to find the llink for you.
 

·
Registered
Joined
·
1,469 Posts
Get the nissan distrib. I know that they are more money but they are a known quantity, The ones from the parts store and E-bay have a much higher higher failure rate. Enough higher that I would not touch one with a 10 foot pole.

That reminds me, I need to return my spare to its rightful owner.
 
1 - 20 of 24 Posts
Top