Nissan XTerra Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
When I was a kid one of the first Nissan's I ever drove was my dad's 88 x cab, 4cyl, auto. We sarcasticly named it the "silver bullet", figured I'd pay homage to the trusty old hardbody. Recently acquired my 03 x, v6, 5 speed, 4wd, 128k several hundred miles away and made a weekend trip of picking it up. I limped it home with minimal repair history, a bad misfire and some worn suspension components. Silver lining was the rancho lift, offset aluminum 16" wheels, and a couple other front end components I'll be posting pics of to try to identify
22581.jpeg
 

·
Registered
Joined
·
16 Posts
Discussion Starter #2
When I got home I immediately ordered complete timing belt kit, ngk plugs, wires, dizzy cap, rotor, rebuilt bosch injectors, quest alternator (NEW!, Motorcraft, $75 shipped on eBay), knock sensor, door pins, and tires. While parts shipped I bought leather interior from 07 Volvo s60r, welded,fabbed and installed those. I still need to run a permanent circuit to them but that will wait til the stereo install.
22580.jpeg
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Tires were delivered very fast and I had them mounted Wednesday afternoon. All of the rest of the parts made it to me by Friday


This weekend's progress:
A friend came over Saturday and we got started on the t-belt. It was my 1st 1 but proved to be pretty simple. No real snags except the crank oil seal didn't want to seat without the spring popping off. Finally got it using a 4" long piece of 1.5" PVC pipe as a driver. We completed t-belt, water pump, thermostat, belts, knock sensor relocate w 99maxima 1, injectors, plugs, wires distributor cap and rotor, fuel pressure regulator and recharged k+n filter.
Everything went pretty smooth except rear hoses on upper manifold, couple cuts and scraped knuckles. I need to figure out how to take pics that are small enough to put in post. Here's Dropbox link for Xterra folder in the meantime

https://www.dropbox.com/sh/5ctmdmdapeqc9ij/AACRG56f_fU670JUbev1qzVsa?dl=0

The engine seems to be running smooth,no misfires, and way more power and throttle response. 1 of the O2 sensors did throw a code, I assume they took a beating from injectors leaking and running rich for several hundred miles, they're old and am going to replace all of them when they arrive tomorrow.

I'm going to try to post a few pictures of current lift and steering setup, the X's setup are new to me and any help ID what's on there for aftermarket and the best path to get the right parts ordered to get the steering play fixed would be helpful
 
1 - 3 of 3 Posts
Top