Nissan XTerra Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi Guys - I have a 2001 Xterra SE and after fueling up I was rolling up to a red light and as I came to the light and stopped the car it struggled to idle and quickly died. I was able to start it back up immediately and drive away but any time I was a slow coast it would idle sporadically and die. I can drive it on a cold motor for about twoish miles before it starts to act up too.

I've changed the fuel filter, fuel sending unit seemed in good condition. Changing spark plugs and wires and distributor just as precaution this week and have checked the possible vacuum lines.

Any clue where else to start?
 

·
Registered
Joined
·
444 Posts
Idle air motor? I would take your TB off and give it a good cleaning...you might have a port plugged with carbon...you could seafoam it too, always a good starting point

Darin
01 Xterra SE 4x4
COMING SOON:
Intake mod, timing belt, hoses, belts
Wish list:
PML, EFan conversion, shocks, 32" tires, and eventually UCA'S
 

·
Registered
Joined
·
2 Posts
First thing you can do is check the transmission fluid. Is that's good then you start getting into vacuum leaks, tps, maf, timing adjustments, etc.
 

·
Registered
Joined
·
16 Posts
Any luck figuring out the problem? This has been happening to me intermittently for the entire 3 or 4 years I've had my 01 X. Tried to figure it out for a while, but it happens so infrequently that I don't even worry about it anymore. Always within the first 5 miles or so after starting, but if you just really step on it for a couple of seconds, it seems to clear right up.
 
1 - 5 of 5 Posts
Top