Nissan XTerra Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
So last month or so I've replaced the whole suspension on my 03 x .. upgraded to some Yokohama MT's and new sway bar bushings and ends.. I may be nuts but it seems like when I let go of the gas pedal, it feels like something is slowing me down at a noticeable pace... feels like I'm in a low gear or that brakes are on still.
Looking for some diagnosis ideas or ways to check to see what it could be... any suggestions or pointers?
On a side note, I have had procomp es3000 for about 2 monts and my ride quality has gone to shit in a hand basket! No offloading in them yet.. is that even possible?? Nose dive on braking and bumps feel like my truck is gonna bust in half!!
 

·
Registered
Joined
·
1,214 Posts
Procomp es3000 shocks are cheap twin tube shocks more than likely not even valve correctly for an Xterra. Probably ride close to the same with the shocks off. They are on par with Gabriel shocks. Those MT tires do not help with coasting off throttle.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Sounds about right on the shocks. Damn! 4 wheel parts can bite a big one! Eh, get what ya pay for I guess.. bilstein best route?
 

·
Registered
Joined
·
1,214 Posts
Yes on the Bilsteins. Up to you if you want 4600 or 5100 series. Do not know if you are lifted or not but get the ones for a lifted Xterra. Same compression length and have longer extended length. Same price either way. The 5100 series are worth the extra price over the 4600 series for what I do offroad. 4x4 parts have both series.
 
1 - 4 of 4 Posts
Top