Nissan XTerra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Recently got myself an 01 Xterra se. Has the 3.3l v6 with 4wd. Bought it with tons of new parts including brake booster master cylinder and only pads. When I hit the brakes they make a hissing noise. Only at a medium pressure. If I hit it lightly it doesn't do it and if I push them down hard it doesn't do it. The brakes are really sensitive if you tap them lightly it throws me forward, so I'm not really sure what could be going on. Master cylinder was a bit low on fluid according to mechanic when I went to get it stickered and he added fluid and bled the brakes but still no difference in that noise. Any help would be greatly appreciated
 

·
Registered
Joined
·
4 Posts
Most likely the brake booster, if you can clamp the vacuum hose to it to check and the noise should go away. Or if the noise goes away with the engine off.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Noise goes away with engine off but the noise can only be heard inside cabin down by pedal. I did figure out whoever replaced the brake booster got a used one so maybe it could also be bad but still not sure.
 

·
Registered
Joined
·
4 Posts
There is a leak in your brake booster diaphragm. The rear seal on the booster is in the cabin of the vehicle your hearing air pass threw it into the engine when you apply the brakes.
 

·
Registered
Joined
·
2,752 Posts
another way to check if its the booster is note how far the pedal goes with engine on, sitting still hitting breaks, then shut off engine and pump them 2x then hit the pedal hard, does it get super stiff or does it slowly drop and get limp? if the latter failed booster
 
1 - 5 of 5 Posts
Top