Nissan XTerra Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Good day

I had my 2005 Xterra at my Nissan dealer for an oil change. They inform me the high mount brake light on my 2005 xterra is out and for $300 they can fix/replace it. I definitely do not have $300 lying around so I start searching online. First thing I find is to check the other rear brake lights and see if they work, they do. So I take a week to find a wrecker with a replacement huh mount, order it, it arrives today, I unhook the old, put in the new and ....... nothing. Still does not work. Any ideas?
 

·
Registered
Joined
·
248 Posts
I am pretty sure that your other two break lights run off the same circuit so the fuse should be fine as well. What I would recommend is to check the wiring next. Check the wiring that joins the hatch to the rest of the body. Open your back hatch and I think it is in the top left corner but not 100% sure on an 05 that is listed in your profile. I think from years of use they can just worn out or broken, or if any moisture got in there they may have corroded. That is where I would look next.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
Took the X in to have the front brake pads replaced under warranty as they were squealing whenever I would brake (they had just been replaced). I mention to my repair guy about the high mount light not working, and I have the new one I purchased with me. He tests them both and they both work. Turns out I had 5 broken wires between the hatch door and the hatch opening in the rubber boot that broke from the hatch opening and closing all the time. Glad Nissan didn't bother to check that??? So the shop repaired the 5 wires (soldered and heat shrinked) and now the high mount works. Silly thing is, I have no idea what else was not working due to the other 3 broken wires as I never noticed anything before or now.

Anyways, issue resolved.
 

·
Registered
Joined
·
248 Posts
Gold star foe me! Maybe it was your back wiper or fluid sprayer that was affected by the other wires. It would only be what ever is mounted on the hatch that would be affected.

Glad you got it sorted out and probably saved a ton of money vs what Nissan would have charged you. And this my friend is why I love this site! Good people, great help!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top