Nissan XTerra Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Hi all

I joined looking for some input on a potential purchase (this week) of a 2002 Xterra. I figured this forum was as good as any, to ask my questions. I've been able to find all sorts of information, just from searches, too.

That said, I have a few specific questions. My current van as 440 on it and it's done, entire front end needs to be rebuilt, rack gone, at least one or two wheel bearings, all other components. So, I am looking at a cheap short-term fix and believe I found one in the 2002 Xterra. I haven't been a kind driver to my mini vans tho can also suck the max value of life from them ... but I want to hear from people who own or know this vehicle what they think of it ....

Previous to owning a lot of dogs, I always had 4 wheel or rear wheels many years ago... I am assuming this xterra will pass a safety (something we need to buy a vehicle in Ontario). BUT the oil pan is rusted out, at least one of the lines on the bottom of the rad needs replacement, I suspect there may be a minor leak on the rear diff ... none of this makes a difference on the safety, but I know it needs to be done ... it had the valve cover gaskets done, is blowing great balls of black smoke right now, running way too rich ... owner previous to this did all maintenance ... in 8 months of new owner I don't think ANYTHING has been done. Nothing. While I generally drive my own oil around 12 to 14 k, and certainly pushed it higher (on 40 k right now over an oil leak I refuse to fix), it's all highway driving, I drive about 70 - 80 km km a year and have for 25 years. This oil is at 9 k and it's all short city trips ...

For what I am spending, it isn't a huge amount of money but I'm thinking if I just do all the basic maintenance, all of it, then it has some serious potential for a reasonable life. The body, mounts, etc all good.

I've owned an 81 Ford Bronco, 94 Chev Blazer and 2002 Ford Explorer ... the 2002 4x xterra strikes me as in between my Bronco and Explorer ... I definitely do not 'need' the kind of 4x the Bronco was but it needs to be better than my Blazer not that it was poor (don't want to shovel the 3 foot plow banks in winter - I want to drive over them - but have somewhat outgrown my desire to squash beaver dams and go swamping tho the xterra looks like it could do it with maybe a lift :D

Anyway, based on description, what do people think of what I found? I think it lacks in basic maintenance ... I made a list of everything I think it needs for that ... but thought to ask, too ... I otherwise have a lot of Alaskan Malamutes and spend a lot of my time, outside, thanks for any help

tanya
 

·
Registered
Joined
·
444 Posts
As long as the timing belt has been done and consistent oil changes, these things get over 300k with regular maintenance...that being said, I am concerned about the black smoke, it isn't/shouldn't be a diesel...if it is running that rich, there is a problem, and could be clogging up cats in the process...oil pan rusted out scares me also, but then again, I don't live in Ontario...but if it is just basic maintenance that it needs, then I would jump on it after having a shop go over it for me just for S&g's

Darin
01 Xterra SE 4x4
COMING SOON:
Intake mod, timing belt, hoses, belts
Wish list:
PML, EFan conversion, shocks, 32" tires, and eventually UCA'S
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
I just found out it needs an exhaust manifold gasket ... I've done a lot of repairs over the years ... not that one ... bcz of the snow, dampness, here if we park outside, on grass, etc, they rot out ... I've rotted them out in various vehicles over that ... thanks
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
It passed safety, nothing required. I actually had the safety redone at a garage I trust ... garage #1 wanted a manifold gasket and muffler gasket done ... around $600 with tax. My garage, decent, honest family business, said nothing wrong and the money better-spent else where ... it does indeed need every other thing I saw, the little stuff, not required for a safety but just simply required ... wrong head lamps make the indicator on dash not work, right? I can't test the head gasket really without a compression test, so I'll get onto that this weekend ... and the oil pan is a mess... saw that on the hoist very clearly worse than when I was under it on the ground, I didn't use the ramps when I looked, myself ... I also tripped off two codes this week ... knock sensor and random misfire, cleared them, and took it out on a major highway and blew the snot out of it ... seems to be cleaning up the carbon deposits and the codes aren't back after 300+ km ... though I will deal with that if I have to. I suspect the injectors need help ... or replacing
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #6 ·
One more question, who ever wants to answer. I am missing something here. I was digging through paper work tonight, the intake, exhaust and plenum gaskets were replaces just under 20K ago ... that the most recent owner did not drive this much ... the previous owner did, and that was where that repair came from. Done at a shop. If I use cruise at 80 to 84 km an hour, it isn't quite right - misses? misfires? Minor, very subtle ... I can just feel it ... you don't when not on cruise ... if I idle on warm starts, smoke. If I hard stop to a stop light or something, smoke. If I 'cruise' gently up to the stop - no smoke. I've improved my gas milage a lot from the Duralube to get rid of the carbon deposits ... I switched to synthetic oil, and filter ... no brown in oil, coolant NOT contaminated ... Filters all good. PCV was totally gooped up with sludge, almost gritty in my fingers but could be dissipated ... I cleaned that tube out, put in a new PCV ... what am I missing? Gaskets with 20,000 km on them (km are a lot less than miles (10 miles is 16 km) should not go bad unless they were poorly installed? What am I missing, combined with above information? I only knew the carb'd stuff ... so all this FI stuff is new to me ... I hope someone can point me into the right direction to look ... I feel a nice, tight, engine, no tranny or drive train problems ... outside of above ... I don't know what is going on ... it runs fine, nice little engine ... cruise at those specific speeds getting an issue means something too I think ... I just don't know, what. Help!

tanya
 

·
Sage Mentor/Moderator
Joined
·
12,216 Posts
Have the spark plugs been replaced?
A LOT of shops/people seem to skip the #6 spark plug when changing the plugs...as the #6 is between the back of the engine and the firewall, and hard to reach if you're not familiar with the techniques, etc.

I've seen rigs with the factory plug still there on 200K+ mileage X's...as every one who skipped it, assumed the "next guy" would change it, etc.

:D

After that, the actual age/mileage of the timing belt, the condition inside of the distributor, exhaust/intake system, etc.

The specific symptoms, at the speed range you mention, can be also checked by seeing if the same speed, in a lower gear duplicates it, or, if the rig speed, and not the engine rpm/load might be involved.

That can help to diagnose the issues.

>:D
 

·
Registered
Joined
·
444 Posts
Maybe a vacuum leak...take some carburetor cleaner and spray around the vacuum lines methodically while running and see if the idle increases. If it does, you have a leak wherever you just sprayed

Darin
01 Xterra SE 4x4
COMING SOON:
Intake mod, timing belt, hoses, belts
Wish list:
PML, EFan conversion, shocks, 32" tires, and eventually UCA'S
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #11 ·
Oh, I have 6 new spark plugs waiting to be installed, along with a few other things ... I'm just trying to ID various issues and 'start' at the right thing if I'm going to need to do multiple things, rather than re-do ripping apart for each thing, if that makes sense. IE if I need to buy the timing belt, new valve covers, etc ...
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top