Nissan XTerra Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
621 Posts
Discussion Starter #1
so for a while ive been overheating and i found i needed to back the screw out and let it run to let the air out. I did that and i realized why it had overheated before. Well it was about 7 months before it did it again. When it was nice and cool out??? it had just passed the middle mark and i knew it because it did it before. I shut it off and the temp kept going up all the wait to just before the line under the h. Started it up and it droped back to normal temp. Im wondering if maybe my tstat is being stupid sometimes and and thinking about gutting it and seeing if that stops it. I feel it is loosing coolant which im thinking was only because i had just shut it off and found my overflow at the minimum. The first time it overheated that thing filled up and i just left it and bled the system and put more in the rad. Do it or dont? Not sure if these heads are bad about going bad when the over heat. im hoping not i mean ill throw new head gaskets on no problem but i just wanna avoid having to do that cause i got my timing belt almost due and this tax return its getting new timing belt kit and every seal on the motor and a distributor. I plan to keep it for a while. I can get my heads redone for 125 and new gaskets too if i should. Which i might do anyways. I just want this ready for college i cant have it breaking done due to neglect so im gonna take care of her lol. But the tstat? Do or dont or other suggestions?
 

·
Sage Mentor/Moderator
Joined
·
12,216 Posts
Do a OBD port reading of the real time temp WHILE the dash gauge is telling you you're overheating.

You can also have a bad dash gauge sensor. The second sensor, used for the ECM/OBD port - is more reliable.
 

·
Registered
Joined
·
621 Posts
Discussion Starter #3
Thanks tj. I found my problem which was the coolant line under the plenum is leaking idk how long it has been leaking but its minimum enough for me to still ride i just keep a thing of coolant incase it ruptures bigger than it is which now its very minimum and every day i drive i make sure its got plenty of coolant which for the past week its damn near the same level it had been. I doubt it has overheated because of what is stated above in my post after shutting it down and i might have saved it. But i found where its going over long periods of time and its gonna be changed for my xmas along with new tbelt and water pump and all my gaskets rear main etc etc. all for 500 i couldnt pass that deal up. Good to have friends =D hes a nissan mech that finished school too so not a shady mech. Thanks for your huge help! I thought i knew what it was but that sensor is off. I had it read by my buddy when i got it to start to over heat. The sensor itself is bad poking at it gives different readings than what was on the scan guage thing. So i dont think ive ever truely over heated it though im glad it is bad because its the only reason i found how i was loosing coolant lol. Again man thanks alot!
 
1 - 3 of 3 Posts
Top