Nissan XTerra Forum banner

21 - 30 of 30 Posts

·
Brooklyn br0
Joined
·
3,087 Posts
Is your auto hub working?
I might have an ABS line around somewhere. If the solder don't work (it should) let me know and I'll look for it.
 

·
Registered
Joined
·
297 Posts
Discussion Starter #22
Is your auto hub working?
I might have an ABS line around somewhere. If the solder don't work (it should) let me know and I'll look for it.
What’s your recommendation to test auto hub working? Do I have to get all the wheels off the ground and try it? I guess I could get in a situation where that front wheel is off the ground and see if she spins but idk where to do that near me
 

·
Registered
Joined
·
297 Posts
Discussion Starter #23
For anybody’s interest, I just repacked the outer bearing and stuffed a bunch of grease into the inner bearing area of the hub, then took a short ride after replacing lower ball joint. The big click noise wasn’t there in reverse or tight turning, maybe a little noise still coming from there though. When I looked into the hub it was clear that the bearings were pretty dry, which made me think that the washer I put on backwards allowed grease to leave the system, and being at 100,000 miles and 17 years old the grease had left in other ways as well, so the clicking and loud metal on metal noises started happening. Hopefully the bearings are all right and hopefully the sound is actually gone!
 

·
Registered
Joined
·
1 Posts
What’s your recommendation to test auto hub working? Do I have to get all the wheels off the ground and try it? I guess I could get in a situation where that front wheel is off the ground and see if she spins but idk where to do that near me
I hope you've taken your vehicle to your nearest mechanic. My mechanic from gjdrivelines.com.au told me to always approach a mechanic whenever there's a vehicle malfunction happening.
 

·
Registered
Joined
·
297 Posts
Discussion Starter #26
I hope you've taken your vehicle to your nearest mechanic. My mechanic from gjdrivelines.com.au told me to always approach a mechanic whenever there's a vehicle malfunction happening.
I haven’t, it isn’t a malfunction, everything’s working properly but there’s a loud noise. I understand why a mechanic would tell you to bring the vehicle to them... I have a lot of fun working on things myself and I’d like to learn as much as I can, so unless it’s really bad or something I don’t wanna do, I plan on continuing my own troubleshooting
 

·
Registered
Joined
·
297 Posts
Discussion Starter #28
Still making the noise? The CV's okay?
Still making the noise. It quieted for a bit after repacking the bearings but seems like it was before now. Because it isn’t a turning issue, more of a reverse issue, I assumed something was attempting to lock up in the hub but failing, so it was sort of clicking in and out of 4wd or something like that. But I have to do the lower ball joints either this weekend or next so I am considering putting the old cv in and maybe it was the cv axle the whole time.
 

·
Registered
Joined
·
297 Posts
Discussion Starter #30
The washer on backwards was a problem but the CV could be broken.
That’d be funny if it was! I’ve just assumed not, because there’s no reason the cv should move when I go from drive to reverse and back, right? Honestly if that’s the issue all along, I would be happy at how much I learned about the hubs and how to remove a cv axle in record time! But also disappointed I got a shit cv axle
 
21 - 30 of 30 Posts
Top