Nissan XTerra Forum banner

1 - 20 of 39 Posts

·
Fishing Guru
Joined
·
596 Posts
Discussion Starter #1 (Edited)
I installed this super quick and will change a few things like the ground having a terminal ring connector. But here it is short and sweet.


First you have to have one of theses


Locate the vac/boost line





Use the connector t in the package with the boost gauge


Run the wires through the firewall gromet

NOW THE POD

Remove the OS handle


Remove stock a pillar plastic (2 bolts)


Mount gauge into pillar pod


Mount pillar pod








Ground the boost gauge. I used a bolt that went to the firewall


Get some power. I tapped into the fuse panel. Use the right side of the fuse or it will not be protected by the fuse. I used a prod tester to see what acc fuse spot came on when turned x on and off when I turned off.


Now your done. Easy as that. I purchased my gauge pod from Gaugepods.com
http://www.gaugepods.com/nissan_t.html

Hope this helps out.
 

·
Super Moderator
Joined
·
8,542 Posts
Good work, POSITIVE rep points for you this time. :) I am moving this to the HOW TO section. Thank you.
 

·
Fishing Guru
Joined
·
596 Posts
Discussion Starter #4
geez, and just the other day i was saying to myself that this forum doesnt have enough DIYs :)

good job bro, i'll be doing a similar writeup soon with oil temp and pressure gauges
Sweet deal I will be tuned in. Any ideas on the othe gauge I should do? I think I am going to do a wideband.
 

·
Super Moderator
Joined
·
8,542 Posts
As in a whole bunch in one?

Air fuel should be one of them maybe, battery voltage, and maybe water pressure?
 

·
Super Moderator
Joined
·
8,542 Posts
You should be able to monitor it though and the AF ratio can be tuned by me :) Not you guys though ;)
 

·
Registered
Joined
·
539 Posts
What does ur boost say at idle vs when reving? Is it neg pressure? I have the gauge but it's not tapped into the right vac line
 

·
Fishing Guru
Joined
·
596 Posts
Discussion Starter #13
idle -18 to -20.
Rev neutral -2
first gear before shift 0 to +1lb
second through rest +2 lbs.
I need to do the K/S relocation mod. lol
 

·
Registered
Joined
·
649 Posts
yeah, stock i was at +5, then flowmaster catback and pushed it to +7, K&N air filter +8, intake resonators removed +9

my KS still clicks off every once in a while, and its a PIA. i'm doing the KS relocation as soon as it warms up alittle
 

·
Registered
Joined
·
539 Posts
I did the relocation, no code in a year. However when I start the truck, it reads -20, as I rev it will go to 0 and sometimes walk past 0 to +1 or 2...are you sure the vac lines actually tell the boost on our trucks>?
 

·
Fishing Guru
Joined
·
596 Posts
Discussion Starter #17
I did the relocation, no code in a year. However when I start the truck, it reads -20, as I rev it will go to 0 and sometimes walk past 0 to +1 or 2...are you sure the vac lines actually tell the boost on our trucks>?
I took my supercharger off and the line I have the boost gauge tapped into taps right into the back of the supercharger. There is a hole in the back of the supercharger on the inside, on the outside is a tube nipple and down the line about 2 feet is where I tapped into just before the oem splitter. If there isnt a better place to tap it into then I don't know where is. No judging by the looks of the inside of the supercharger I AM going to install a oil catch. There is a low amount of blow by going from the valve cover to the supercharger.
 

·
Fishing Guru
Joined
·
596 Posts
Discussion Starter #18
Why does the supercharger make a quiet grinding noise when you close the bypass acuator? Seems like it shouldn't do that. Also have you ever had someone read your boost gauge when you close the bypass by hand? I would think you would jump to 0 boost and when you rev go to 7-9 lbs.
 

·
Fishing Guru
Joined
·
596 Posts
Discussion Starter #19
I did the relocation, no code in a year. However when I start the truck, it reads -20, as I rev it will go to 0 and sometimes walk past 0 to +1 or 2...are you sure the vac lines actually tell the boost on our trucks>?
The bypass acuater opens when you are revving in neutral hence the low amount of boost. If not for the grinding noise I would just zip tie the acuator closed. LOL. Probably not a good idea.
 
1 - 20 of 39 Posts
Top