Nissan XTerra Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Any ideas why my cruise control stopped working in my 2001 4WD SE model? I heard something about a plastic button somewhere. Any ideas on how to fix welcome.
 

·
Registered
Joined
·
255 Posts
Crawl under the drivers dash and take a look at the brake pedal. There are two plastic "buttons" on the brake pedal that contact stationary switches when the brake pedal is at rest (you aren't pushing it). One engages the brake lights, the other allows the cruise control to function. If the one for the cruise is gone it will never engage since it thinks the brakes are always on.

If you find the button missing it probably deteriorated into several pieces on your floor. I would suggest replacing that one AND the brake circuit one at the same time since its probably on its way out as well. When the brake one goes and you don't know it, say goodbye to your battery and several bulbs. Ask me how I know that ha.
 

·
Registered
Joined
·
621 Posts
I got a push pin like one would go into your wheel well to hold the plastic and it's worked like a charm. It's up behind the pedal.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks for the replies. Fuses are all good. I'll look at the plastic buttons on the brake pedal. Will let you know how they look. What is the official name of the these little buttons?
 

·
Registered
Joined
·
255 Posts
Thanks for the replies. Fuses are all good. I'll look at the plastic buttons on the brake pedal. Will let you know how they look. What is the official name of the these little buttons?
Pedal stops:

http://www.summitracing.com/parts/r...RdJTM8ae3pWEV-1aJ6cUviSrB_5uEWrP9kaAicy8P8HAQ

The OEM ones used to be on Courtesy Nissan parts site but the new database is horrible. I don't see the OEM ones anymore but as long as the size is the same it shouldn't matter. Some people will even use a small screw and nut but thats a little harder to install since the space is pretty tight.
 

·
Premium Member
Joined
·
8,519 Posts

·
Registered
Joined
·
211 Posts

Attachments

·
Registered
Joined
·
1 Posts
My cruise light on my 2003 Nissan Xterra SE comes on but it won't set. I will try this.

Also, my headlights won't come on, neither will my tail lights, but my emergency flashers work and when I depress the brakes the lights come on but don't stay on. Also my interior dash board lights do not work. We keep replacing the fuse under the hood but they keep blowing almost as soon as they are replaced. Any thoughts on this issue?
 

·
Registered
Joined
·
384 Posts
it's common on those cars. check your sidelights by your headlight assembly. sometimes the socket of the bulb touches glass of the housing or whatever metal is next to it.
 

·
Registered
Joined
·
3,391 Posts
you definitely have a short somewhere. as mentioned above check the yellow lights beside your headlights they maybe shorting, if not it really could be in any part of the circuit the fuse(s) that are blowing control
 

·
Registered
Joined
·
13 Posts
Thanks so much for this thread. Cruise stopped on my 2K X and I was pretty bummed about it. So relieved that it turned out to be a $5 part!
 

·
Registered
Joined
·
3,391 Posts
Thanks so much for this thread. Cruise stopped on my 2K X and I was pretty bummed about it. So relieved that it turned out to be a $5 part!
thats just what we do here, get stuff solved.
 
  • Like
Reactions: OKCchemist

·
Registered
Joined
·
1 Posts
So I have a 2002 Nissan Xterra with the supercharger. so I can activate my cruise control while driving and it will work or a while then the revs with shoot up and the cruise will shut off but the SET light of the dash will start flashing any ideas?
 
1 - 19 of 19 Posts
Top