Nissan XTerra Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
We bought my daughter a 2002 a month ago with 144,000 miles and it was great. All of a sudden it was eating gas (more than usual) and then she told my husband it was taking longer to start. But she is 16 so... anyway it stalled and now it will crank and not start. We have replaced battery, MAF, ECM, fuel sending unit, fuel filter, Vapor Canister Vent Solenoid, plugs, wires all fuses and as of today the distributor. As I said it cranks and we are really just trying to learn and my husband works a lot so I try... lol Please help!!!!
 

·
Registered
Joined
·
745 Posts
Is the check engine light on? Have you had the codes read? Not all codes will trigger the CEL.

It might be the Fuel Pressure Regulator. If the diaphragm is leaking it will pump raw fuel into the intake manifold. I've never heard of one leaking so bad that it flooded the engine, but I suppose it's possible.

There are two small vacuum lines off the back of the intake manifold. Turn the key to the on position so that the fuel pump charges the system. Disconnect the two lines from the back of the intake manifold. If gas dribbles out of either of them the FPR is bad.

At that mileage, if you haven't changed the fuel filter, you should. Its a simple small canister on the first generation X and doesn't require any special tools. You can get one for under $15. A clogged filter can cause the issues you are experiencing.
 

·
Registered
Joined
·
745 Posts
Another fairly simple thing to check is the EGR valve (Exhaust Gas Recirculation). They sometimes get stuck open due to carbon build up. They are supposed to be closed in a cold engine.
 
1 - 4 of 4 Posts
Top