Nissan XTerra Forum banner
41 - 50 of 50 Posts

·
Registered
Joined
·
9 Posts
My 2002 xterra had same symptoms today. What was the result of your troubleshooting? This was like reading a long novel only to find the last chapter ripped out ..
 

·
Registered
Joined
·
6 Posts
My 2002 xterra had same symptoms today. What was the result of your troubleshooting? This was like reading a long novel only to find the last chapter ripped out ..
Anybody ever say what the problem was? My 03 isn't quite as bad as described but same basic problem
 

·
Registered
Joined
·
9 Posts
I replaced my distributer and my problem resolved immediately. Was simpler than I thought. I have not manually set the timing yet, running fine no change in gas sugar. Bearing was bad on distributer. I bought a new bearing so now have a backup. 😀
 

·
Registered
Joined
·
6 Posts
More or less almost exact same symptoms as OP but not as frequent and I've only had the problem after longer drive times. I have gone months in between at times with no problem
Do you have a minute to describe your specific problem?
 

·
Registered
Joined
·
6 Posts
I replaced my distributer and my problem resolved immediately. Was simpler than I thought. I have not manually set the timing yet, running fine no change in gas sugar. Bearing was bad on distributer. I bought a new bearing so now have a backup. 😀
Did you get an OEM distributor?
 

·
Registered
Joined
·
9 Posts
mine did that too. Was intermittent for almost 1 year. I thought bad fuel. But I imagine the bearing probably gradually goes bad. It is an easy fix. Rock auto for low price quick delivery.
 

·
Registered
Joined
·
6 Posts
I was thinking fuel too at first, then I was thinking maybe a small vac leak. Distributor never really crossed my mind until this forum. Thanks for the response and hopefully solving my problem as well
 
41 - 50 of 50 Posts
Top