Nissan XTerra Forum banner

1 - 5 of 5 Posts

·
Registered
2002 Nissan Xterra Red se
Joined
·
1 Posts
Discussion Starter #1
My 2002 xterra was vandelized and my pioneer stereo was stolen.. the idiot or idiots that did it tore up the console and dashboard..
been repaired but..
the blinkers and 4way dont work even after the console and wiring harness were replaced..
anybody go know what to check or replace??
76835
 

·
Registered
2001 Xterra 4WD Auto 3.3L NA V6
Joined
·
770 Posts
Start with fuses under the hood as well as to the left of the driver's knee.

If you're comfortable with wiring, the FSM can be downloaded here. Just pick the correct model year.
 

·
Registered
03 XE A/T, SC coming soon
Joined
·
1,089 Posts
The turn signals won’t work unless the hazard switch is plugged in. Try pressing the hazard switch and trying again. These switches do fail and they were discontinued years ago
 

·
Registered
Joined
·
11 Posts
Had this issue in my GTO although be it not through vandals, my hazard switch was not plugged in all the way after I painted my dash trim. Also after checking fuses, check with a volt meter or test light that there is power going to that hazard plug. If correct voltage is going and still not working after being plugged in, it may be the plug. Also check the ground side as well since you said the harness was replaced and make sure you have a good ground. Could be something simple.
 

·
Registered
2002 3.3 NA 5 speed 4x4
Joined
·
33 Posts
Had this issue with my 02 when I bought it, went though and found 2 or 3 blown fuses and still had an issue with my console 12VDC outlets...found last time it was removed, someone didn't plug them back in.
 
1 - 5 of 5 Posts
Top