Nissan XTerra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Hello- I had been thinking my battery was getting weaker and was maybe due for replacement. So I picked up a new battery to do the switch at home. Well when I got home I could tell the battery ports were not close enough to the edge of the battery for the positive cable to sit on there correctly but I could just barely hook it up on there, so I did. I go to start it and it wont turn over, no power to turn the truck over. I start checking fuses and find one fuse blown for the radio, so I replaced that. Checked the fuses for the starter and no blown fuses. So right now I have power for the lights, fans, radio etc. but not enough power to turn the truck over. Could it be one of those large fuses for something? Or something else? Thank you in advance.
 

·
Premium Member
Joined
·
8,519 Posts
I am thinking more on bad starter take it off and have it checked for at Auto Zone ,is there any oil dripping on it from passenger side valve cover oil leak ?
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
I am thinking more on bad starter take it off and have it checked for at Auto Zone ,is there any oil dripping on it from passenger side valve cover oil leak ?
My buddy was under the car grounding the starter(I believe that's what it's called) while I was turning the key and the starter was spinning and sparking. Just seems so weird that all I did was replace the battery and all this stuff went wrong with the blown fuse of the radio and it not starting now. The reason I initially thought it was the battery was my the dinging of my truck when I would leave the keys in the ignition and leaving the lights on. Then I went to pick up my kids yesterday and left my lights on for like 5 minutes and then my truck barely started.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #4 (Edited)
I am thinking more on bad starter take it off and have it checked for at Auto Zone ,is there any oil dripping on it from passenger side valve cover oil leak ?
Before I go buy another starter I just had another question to make sure I don't more of an issue. I checked all my fuses and all look good. When I turn my car to the first notch when all the lights come on(battery, oil lights etc) no lights come on. I also dont seem to have windshield wipers or no lights on the defrost or A/C lights. But the fans work, headlights and dash lights work, but no interior lights. Any ideas what that might be? I wouldn't think it would be associated to the starter??
 
1 - 5 of 5 Posts
Top