Nissan XTerra Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all,

I changed my alternator 3 times and batteries 2 times with my issue.

I left my X at a 4wheel parts shop for Leaf springs and i asked to check the electrical issue and they said everything is alright.

Later, the dealer told to avoid buying aftermarket alternators because all their Xterra customer's had the same issue as me. Everytime i drove a bit then stopped at red light, my voltage gauge tend to go up and down until its time to drive again.

Did anybody ever experienced this?
 

·
Registered
03 XE A/T, SC coming soon
Joined
·
923 Posts
I have seen aftermarket alternators fail prematurely. Lately I’ve been seeing more remanufactured units fail even when purchased from Nissan. Without knowing how high or how low it’s going, I couldn’t make a good recommendation. Often times at idle the voltage will be lower especially with more loads on
 

·
Registered
Joined
·
78 Posts
I have gotten remanufactured alternators that were dead in just a few days, the replacement of the replacement died in a month. At the auto parts store they said this was normal and I would eventually get a "good one". And they were right after swapping the alternator 3 times I got one that is still going years later. This was not on an xterra it was my other vehicle , but it could happen to any vehicle. The original alternator died because I was fording a stream and it was deeper then I thought it would be.

The tricky part is as the remanufactured alternators were dieing they would work some of the time. So you check it when first starting the car and it was fine, then as it got hot it would not work right.
 
1 - 3 of 3 Posts
Top