Nissan XTerra Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
HELP PLEASE. So I was driving and noticed that my car was at the (H) on the temp. No smoke or anything but I do remember yesterday when I started it, it took 2 times to get it started I didn't think much of it but now I'm worried. I did notice when I was driving back to work at a stop light it gets hot, but when I drive it it starts to cool down. Any ideas? I'm not mechanically inclined - but know a couple of things. I did get my oil changed two weeks ago, and they checked all the fluids as well.
 

Attachments

· Registered
Joined
·
32 Posts
Could be a thermostat, or a fan clutch or a head gasket. Looks like your engine light is on may want to check the code. I recently had that problem, the temp gauge will rise to almost H when stopped or going up a hill but will return when the car moves. The mechanic that i used sucked(i will never bring a car to him again as the only reason was I just bought the car was because it had a warranty and place where i got said to bring it to him as he knows how to deal with the warranty company) started by changing the thermostat gave car back, happened again, then replaced the radiator, gave car back and happened again, then noticed coolant was in the oil so he diagnosed it as a head gasket then when he got to it said the head was fine but was a cracked cylinder head. He had the car for 2 months.
 

· Registered
Joined
·
257 Posts
Also check the coolant level under the cap (wait till its cold!). Something else you can do is have someone grab the upper radiator hose when its running (it will be hot!) while someone revs the engine to see if you can feel flow. If not, pump could be bad.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top