Nissan XTerra Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2002 XTERRA 6 cylinder that all of a sudden started running rough(it shakes the whole rig)when your running down the road. It stops when you accelerate or let off the gas and the SES light flashes.Hooked up scanner and it read #2 cylinder misfire and P0328 knock sensor 1 circuit high input (bank 1).Any help would be greatly appreciated
 

·
Registered
Joined
·
5,824 Posts
DYI a flashing CEL means a catalyst-damaging misfire and you should not drive it, at all. Good luck figuring it out. Best to start simple - when was the last tune up, etc.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Replaced valve cover gaskets,throttle body gaskets,timing belt,and water pump this summer.would of relocated knock sensor if i known about where it was and what a pain it is to replace.just got plugs and wires for it.Should i replace the cap and rotor as well?
 

·
Registered
Joined
·
5,824 Posts
Yes definitely.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
found cracked distributor cap and a plug wire that a mouse decided to snack on. replaced cap rotor bug and 1-5 plug and wires. ran out of time for #6 .can it be changed without pulling the hole throttle body and everything?
 

·
Registered
Joined
·
808 Posts
Yep not a problem. Just a bit of fiddling down back clipping it on. Helps to follow the same angle as the 2 and 4 . Try pulling it out from the back and go right back the same way. It's the same depth as the other two.
 

·
Registered
Joined
·
455 Posts
Also, unless you're x is supercharged you can safely ignore the knock sensor code. If it IS supercharged. Either relocate or run good gas and bypass it with the resistor mod.
 

·
Registered
Joined
·
2 Posts
Went through same thing. Turns out my x likes to eat distributors for some reason. I just replaced it a second time. I wish I knew what caused that so I could stop it.hope you got yours running again.
 

·
Registered
Joined
·
18 Posts
Mine is running better after changing the air idle control valve & pouring in some Lucus oil fuel injector cleaner into the gas tank. The idle is much smoother now. I still have a little hiccup from time to time but nothing as rough as before. I only put about 20 miles on the truck since changing the parts out. So far so good. It seems to be running better each time I drive it. Only time & more miles will tell.
I did change the distributor just for good measure. I really didn't see any thing wrong with the old one after taking it off.

Thanks for the help.
 

·
Premium Member
Joined
·
8,519 Posts
Went through same thing. Turns out my x likes to eat distributors for some reason. I just replaced it a second time. I wish I knew what caused that so I could stop it.hope you got yours running again.
How much did you pay for dist and did you get on ebay ?
 

·
Registered
Joined
·
18 Posts
I got my distributor from Rock automotive on-line for a little over $130. Had good results getting stuff from them. Maybe your timing is off & chewing up the distributor.

I think the biggest difference on mine came from changing out the air idle control valve & adding the Lucus oil fuel treatment.

Each time I drive the truck it seems to be getting better. Went for a 15 mile ride today & made a couple of stops along the way. Every once in a while it will still have a very brief misfire at a stop light then it evens out quickly & idles smoothly again. It doesn't constantly misfire at idle like it did before when hot. I would say it's a 90% improvement over the way the X was performing before.

I'll update more when we get some more miles logged on the X. I don't drive it everyday since the knee problem & being out of work. The knee is feeling a lot better.

I hope others have success in getting their X's running right. I love mine & would hate to replace it. It still looks good & serves my needs from hauling dogs, bikes & yard supplies.
 

·
Registered
Joined
·
2 Posts
Negative the first one my mechanic got from nissian this one I got from Napa myself and installed now it pops both catalyst inefficient and the trips knock sensor. I think I may need to retard the timing or advance it to smooth out the timing to clear codes
 

·
Registered
Joined
·
18 Posts
I wonder when these things get old if the convert clogs up & is causing these problems. I went threw the same thing with an old jeep CJ7. Did all the usual tune up shit & it still would idle rough. One day driving to work I heard a loud explosion under the truck. The converter blew-up the thing was glowing cherry red from the heat. ever since that happen the truck ran better than when it was new.
 
1 - 15 of 15 Posts
Top