Nissan XTerra Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My wife's 2002 3.3L Xterra engine just started dying. After sitting for a while it restarts without any problem. And checking it over and over it consistently does the exact same thing. Starts without any problem, runs at idle, dies about 5 min. later then if you try to start it immediately again it runs very rough. It also bogs down if I gun it. It's thrown P0152 (o2 sensor), P0328 (knock sensor) and P0102 (MAF sensor) codes but I think they've been doing this for a while so I don't believe it's the main cause of the problem but could it contribute to it making act that way? The battery and alternator tested fine, next thing is replacing the MAF sensor (needs it anyway) fuel filter and possibly pump. But a problem with that much of a consist pattern every time makes me believe it's something completely different. Any ideas? Thanks in advance.
 

·
Registered
2015 Xterra Pro-4X
Joined
·
1,282 Posts
My wife's 2002 3.3L Xterra engine just started dying. After sitting for a while it restarts without any problem. And checking it over and over it consistently does the exact same thing. Starts without any problem, runs at idle, dies about 5 min. later then if you try to start it immediately again it runs very rough. It also bogs down if I gun it. It's thrown P0152 (o2 sensor), P0328 (knock sensor) and P0102 (MAF sensor) codes but I think they've been doing this for a while so I don't believe it's the main cause of the problem but could it contribute to it making act that way? The battery and alternator tested fine, next thing is replacing the MAF sensor (needs it anyway) fuel filter and possibly pump. But a problem with that much of a consist pattern every time makes me believe it's something completely different. Any ideas? Thanks in advance.
Check engine codes are usually pretty good clues. You might want to address the 102 to start and move on from there. They say you may ignore the 328 if your motor is not supercharged.
 

·
Registered
2004 Xterra XE 4WD Auto 3.3L NA V6
Joined
·
1,658 Posts
Use OE parts. You've been warned. You can scan other threads and so many of the old-timers say it over and over, so I'm just repeating what they say. I'm not the smart one, but just smart enough to recognize good smarts when I see it.
 

·
Registered
Joined
·
177 Posts
My wife's 2002 3.3L Xterra engine just started dying. After sitting for a while it restarts without any problem. And checking it over and over it consistently does the exact same thing. Starts without any problem, runs at idle, dies about 5 min. later then if you try to start it immediately again it runs very rough. It also bogs down if I gun it. It's thrown P0152 (o2 sensor), P0328 (knock sensor) and P0102 (MAF sensor) codes but I think they've been doing this for a while so I don't believe it's the main cause of the problem but could it contribute to it making act that way? The battery and alternator tested fine, next thing is replacing the MAF sensor (needs it anyway) fuel filter and possibly pump. But a problem with that much of a consist pattern every time makes me believe it's something completely different. Any ideas? Thanks in advance.
Two reasons I can think of 1. fuel pump 2. timing belt
 
1 - 4 of 4 Posts
Top