Nissan XTerra Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
2001 Xterra - Runs with rough idle and stalling out at stoplights and while coming to a stop. Cranks back up and keeps going after shut off. During the last month we have replaced Knock Sensor, timing belt, replaced plugs and wires and it's on a 2nd new distributor in 4 weeks (changed out after code kept coming back). Just got it back with the SES light finally off. Drove it maybe 20 miles, came to a stop and it lost RPMs and started running rough again. Running out of ideas. Mechanic is pretty familiar with Nissan and is a really great mechanic, but it has all of us at a loss. He said he checked the MAF sensor and it seems to be ok. Any ideas would be greatly appreciated. For some reason I keep thinking it is that MAF sensor, but that is just a gut feeling due to researching the symptoms our X is having. Thanks!!
 

·
Premium Member
Joined
·
8,525 Posts
Have you changed the crank sensor its only $20 ,i think i would do that first before Map sensor a good one is $150 , dont get MAP on ebay no good.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thank you for your reply!! I have been reading several other threads here and that makes sense! Does the fuel sending unit also cause these symptoms in the Xterra? Thanks for lending your knowledge. This forum is very helpful!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Fuel filter changed over a year ago and fuel filter has been changed. Just bought a new distributor from the Nissan dealership after installing 2 from Advance Auto that seems to throw the Cam Sensor code back on. Mechanic said this model required OEM parts. Still having the same problem. Rough Idle, cutting off at stoplights and Engine light came back. Checking code on Monday. Mechanic stated it's not the MAF or the crank positioning sensor, but symptoms are telling me it's the sensor. I love my Xterra, but this has been like trying to find a needle in a haystack.
 

·
Registered
Joined
·
444 Posts
Check your fuel level sending unit where the two plug port is and make sure there is no corrosion anywhere, even look into the white plastic and make sure the two electrodes aren't green...mine just broke on me and started doing similar things, though mine only lasted a few hours before it failed completely due to me unplugging the connection and pulling out one of the contacts. Also, crank sensor could be failing. I would start with going through every electrical connection having to do with fuel and spark and clean with contact cleaner and add dielectric grease. That way you know it isn't a connection problem

Darin
01 Xterra SE 4x4
COMING SOON:
Intake mod, timing belt, hoses, belts
Wish list:
PML, EFan conversion, shocks, 32" tires, and eventually UCA'S
 

·
Registered
Joined
·
36 Posts
I had the the EXACT same issue also massive lose of power uphills and higher speeds. My motor would complete shut off, turn right back up but turn off at red lights and idle crazy too. I finally fixed it today!
I got new cats and it ran slightly better however the big deal was my Idle Air Control valve! it threw no codes too! Please if anyone is having this problem dont waste your time on new disturbers! Id first check fuel system, then cats then TPS sensor then finally the idle air control valve. Its located underneath the intake manifold, driver side.

I read soooo much BULLSHIT on nissan forums about this issue. No one brings up the IAC valve, partly due to lack of codes on OB2!

PEOPLE CHECK YOUR IAC valve if your nissan has massive lose of power and shuts off! you welcome ;)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Thank you so very much!! Just left mechanic and they are stumped with this code 340 popping back up with the new dist installed. Going to go through and check connections and look into to IAC valve! Most advice has led me back to the distributor or CPSensor. I will update as soon as I know the fix..hopefully soon and inexpensively :) Everyone on this forum is awesome for their sharing knowledge, thoughts and experiences!!
 
1 - 9 of 9 Posts
Top