Nissan XTerra Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
So got the dreaded p0340 code for camshaft position sensor, it runs but a little rough.
I have a 2001 parts se automatic with a brand new distributor in it. Can i swap the camshaft position sensor or am i buying a new distributor? Also ive heard that there are 5 or 6 different casting numbers for the distributors on the 1st generation xterra, is this true? Because none of the suppliers seem to ask about that... how would i go about getting the correct on if that is true?
 

·
Registered
03 XE A/T, SC coming soon
Joined
·
1,226 Posts
I doubt there’s that many. There may have been 5 factory part numbers but they probably all supersede to the same one now. I keep a test distributor at work that I’ve used on xterra, pathfinder, and frontier. Beats pushing it in
 

·
Registered
Joined
·
1,112 Posts
Unfortunately you're stuck buying a new distributor. Do try cleaning up the wire terminals first. There is the possibility that it has a poor connection. Also inspect the wire harness. Definitely buy a NISSAN or HITACHI dizzy. The ones you buy from Nissan will likely be stamped HITACHI and come in a Nissan box or bag at a couple hundred dollars more. Expensive packaging. I don't recommend an aftermarket, but if you do go that route then go with the Autozone Gold. At the very least it has a lifetime warranty, so if it stops working you can trade it in for another one that doesn't work. But seriously, the aftermarket generally have issues with the cam sensor that is likely due to the sensor being too small, not sensitive enough, and just generally not quite to spec. The gen1 is pretty picky about pretty much all of it's ignition related electronics (plugs, dizzy, etc). It's best to stick with OEM and/or the OEM manufacturer (HITACHI and NGK).
 
1 - 3 of 3 Posts
Top