Nissan XTerra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hello everyone - totally new here. Just got an 06 xterra offroad edition 4wd w/19k Mi on it. LOVE IT. However, it has a problem. Occasionally, it will not start unless I put it in gear, then take it out again. Initially, i thought i was just dead in the water, since it would almost, but not quite, engage... this is when i noticed that the little cover for the shift lock was missing. With the ignition in the off position, I shifted from park into drive and back into park... and then the engine started up with no problem. I've had this problem 3 times now, and each time I put the keys in the off position, engage the shifter, and put it back into park and it starts right up.
Anyone have any idea what is causing this? i want to get it to a dealer, but can't for a few days & am curious what I can do to help the situation in the mean time.
THANKS!
~C~
 

·
Premium Member
Joined
·
11,798 Posts
I don't know exactly what to tell you since I have a 1st gen ('00-'04) and I'm not sure how similar the cables and guts are on yours. But there is a cable that is attached to the shifter under the console. It may have come loose from it's clip. This cable is tied into the ignition so that the ignition will only work when the transmission is in park or neutral. If the cable is loose, the tension will be off and the ignition lock won't unlock when it's supposed to. At least that was the issue with mine. It was doing the same thing after I had done my body lift because I forgot to put the cable back in it's bracket.
 

·
Silver Submarine
Joined
·
10,979 Posts
IMO Don't mess with it. Since its new let the dealer take care of it. If you start taking stuff apart to see whats wrong and the dealer see's that its been messed with they will blame you and won't fix the problem. They will find any reason not to do warranty work. Not saying this for all dealers but for most.
 

·
Registered
Joined
·
1,494 Posts
Yeah let the dealer mess with ity since it should still be under warranty. If you want to do it yourself, it sounds like the shifter safety switch needs adjusting slightly.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
After months of intermittent starting issues, which would NEVER occur @ the dealership when in for service, the dealership finally pulled and replaced the whole on-board computer as well as installed a new ignition system and programmed new keys for it. Since then, no problems! Thanks for all the input!
 
1 - 5 of 5 Posts
Top