Nissan XTerra Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
Hey everyone,

I found that my '04 x s/c is making a noticeable rattling noise, specifically around the 2200 rpm mark.

I have had two shops look into very briefly. They both said that the heat shields are tight and that they believe IT IS exhaust related.

Weird thing is that this sound CANNOT be replicated at idle. Truck must be in drive.

My assumption is that the vibrations are excessive at this rpm and is in turn making the noise. It almost sort of sounds like a grinding and rattle at the same time. I'll try and get a video going soon.

Has anyone experienced a rattle at such a specific rpm? Nissan dealership quoted me $60-$120 just to diagnose. Could the cats be falling apart? Should I buy new cats and just have them replace it? Or look into replacing the whole exhaust system?

Timing belt job is coming up so budget is to be quite restricted.

Thanks for viewing!
 

· Registered
Joined
·
840 Posts
Check to see if your o2 sensors are tight. I had an issue on a previous truck where a mysterious rattle would appear and one day I found my o2 sensors had come loose. It was a very annoying sound and a reoccurring problem with that truck. Anywho worth a shot to give em a check.
 

· Registered
Joined
·
55 Posts
Discussion Starter · #3 ·
Check to see if your o2 sensors are tight. I had an issue on a previous truck where a mysterious rattle would appear and one day I found my o2 sensors had come loose. It was a very annoying sound and a reoccurring problem with that truck. Anywho worth a shot to give em a check.
Thanks jhill15, I'll give that a look. May I ask how accessible the o2 sensors are on the xterra? Are they able to be accessed quickly or do I need to allocate a bit of time to search for them?

Thanks!
 

· Registered
Joined
·
840 Posts
I'm pretty sure you can access them from under the truck...don't hold me to that lol. At least the ones behind the cats. You my have to reach down from the engine compartment to get the 2 in front of the cats.
 

· Registered
Joined
·
42 Posts
I have an 08 that's been to the dealer 3 times for a rattle/thrashy kinda noise... doesn't do it all the time and only on acceleration . All the tec's say its a sheild, to me it sounds like its my exhaust sheilds . If you get an answer before I do make sure you let me know !
 

· Registered
Joined
·
55 Posts
Discussion Starter · #6 · (Edited)
I have an 08 that's been to the dealer 3 times for a rattle/thrashy kinda noise... doesn't do it all the time and only on acceleration . All the tec's say its a sheild, to me it sounds like its my exhaust sheilds . If you get an answer before I do make sure you let me know !
Finally found the cause of the issue. My mechanic pointed it out and fixed it for free. It was the transmission heat shield. It is the greyish coloured shield in the picture. They simply bent it back and it sounds about 95% better.
 

Attachments

1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top