Nissan XTerra Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey all just bought an 01 Xterra with 220k miles on it...everything works fine except the radio and no AC...anyway i took it for a longer drive today than my initial test drive...3 lights came on after i stopped at a store and started it back up again...the AT temp oil, brake and battery lights...thing is its a manual transmission.. why is there an A/T oil light coming on?? did they get lazy and just make 1 dashboard for it?? or maybe it was automatic and someone put a stick in it?? any thoughts or answers?
 

·
Registered
Joined
·
78 Posts
finding a good alternator is more the problem i see than replacing it
Vehicle is looking great for the year and mileage. What makes you think you need an alternator? Is it making noises? Do you have a volt meter to check the voltage it is providing the battery when the vehicle is running at idle?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
Vehicle is looking great for the year and mileage. What makes you think you need an alternator? Is it making noises? Do you have a volt meter to check the voltage it is providing the battery when the vehicle is running at idle?
Thank you...no noises, just looking at other posts that had the same 3 lights on it seems to be the alt....i will check the voltage though
 

·
Registered
Joined
·
30 Posts
Hey all just bought an 01 Xterra with 220k miles on it...everything works fine except the radio and no AC...anyway i took it for a longer drive today than my initial test drive...3 lights came on after i stopped at a store and started it back up again...the AT temp oil, brake and battery lights...thing is its a manual transmission.. why is there an A/T oil light coming on?? did they get lazy and just make 1 dashboard for it?? or maybe it was automatic and someone put a stick in it?? any thoughts or answers?
I have never seen a AT temp light in a manual. Where is it in the gauge cluster? I will see if I have a space for one.

Edit: I found where it would be, I have never seen it on. Checking the Alternator sounds like a good idea. I had the Alternator on another car get submerged and went out it and a few lights came on besides the Alt. light, I think the brake light was one of them.

The Alternator may work until it gets hot and then the voltage starts to fall? or it may be totally bad. What voltage do you get on the battery when the engine is running?
 

·
Registered
Joined
·
78 Posts
That's a good normal charging voltage coming from the alternator. My charging voltage is normally 14 and change also. Certainly your charging voltage seems to be in order. I thought the original 01terradriver was going to respond to the charging voltage.
 

·
Registered
Joined
·
50 Posts
The AT temp light has been a mystery for me. It seems some AT cars don't have it while others do. I thought they were only supposed to be in AT 4x4 after a certain year. Anyway, are you sure it's an AT temperature light? Is it possibly the ATP light? It would still be weird but this light comes on when your transfer case is in neutral (or maybe close to neutral) and your transmission is in park. It's a warning so that your vehicle doesn't roll away because the transfer case isn't engaged.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
Charged the battery and checked it at full charge it was 14 then took it for a decent drive, 3 lights came back on and it went back to 11..I bought another alternator and belt
 
1 - 17 of 17 Posts
Top