Nissan XTerra Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
214 Posts
I'm kinda curious about that myself. I'm guessing you'd have to spoof the O2 sensor inputs to the ECM at nominal and would possibly lose some MPG's in the process.
 

·
Premium Member
Joined
·
8,525 Posts
Your ECM light would stay on , you would loose ECM tuning , and if you have state inspections or emissions testing you would fail.
 

·
Registered
Joined
·
214 Posts
Your ECM light would stay on , you would loose ECM tuning , and if you have state inspections or emissions testing you would fail.
I wonder if it would even start? I guess an easy way to find out would be to disconnect the O2 sensors and see what happens.
 

·
Registered
Joined
·
3 Posts
To answer your question:

I just recently bought an 01 X from a guy in CA. The previous owner had removed the OEM exhaust system, took out the cats so he could sell them, and rigged up his own system. The 02 sensors were never re-installed, because there were no cats to put them in. The truck ran fine without the sensors, albeit it ran very rich. When I first bought it, I noticed that it was getting terrible gas mileage (5-6 MPG). I took the truck to a local shop, and the guy installed one 02 sensor in the driver side pipe because it just happened to have a bung in it. After having the sensor installed the truck now gets about 10-12 MPG.

Eventually I will get around to ordering new cats, pipe, and a muffler and rebuilding the system properly.
 

·
Registered
Joined
·
214 Posts
"When I first bought it, I noticed that it was getting terrible gas mileage (5-6 MPG)..."

Wow! Those are some expensive miles!
 
1 - 8 of 8 Posts
Top