Nissan XTerra Forum banner
transmission
1-20 of 79 Results
  1. Repair Questions
    Hello fellow nissan lovers, My fiance's xterra (203xxxmiles) took a dump on us. She's a teacher and needs her ride running. So the issue we have ran into is the truck just wont go. It starts fine. Does its little high idle. Then when we shift into reverse we can feel the transmission catch...
  2. Repair Questions
    I've done hours of research but cannot seem to find the answer I'm looking for :eek: I have a 2005 Xterra that has a trashed tranny. Up to what year are transmissions interchangeable without modifications?
  3. Repair Questions
    How do I find out which tranny I have?
  4. Modification Questions
    Does anybody have any experience with JDM transmission in our trucks?
  5. Repair Questions
    I have an 01 RWD V6 that will not shift into drive until after it's warmed up. It shifts into 1st and 2nd just fine, but it won't shift into drive until warm. I just dropped the pan, drained about 4 to 5 Q, replaced the filter/screen and gasket, and added new ATF (about 3.75Q). I still have...
  6. New Member Introductions
    I don’t know what to do. Whenever it snows and the roads are slippery the engine seems to do a jerky stall every couple Only when raining or snowing or if roads are slippery. 2008 Nissan XTerra HELP
  7. Repair Questions
    So, I need to thank those of you who replied to my previous post here (especially @XT2015). I've been meaning to get in here and post this for a few weeks now, but just haven't gotten the chance until today. Here's a short story: After a while of not getting around to replacing the radiator...
  8. Repair Questions
    I am new to owning as 07Xterra and it is having trouble accelerating for passing and won't let engine go over 4000 rpms and delays shifts till it hits a certain speed and rev. This is only happening when the engine is warmed up and driving 10+ min. On cold start it seems to run great. The engine...
  9. Repair Questions
    I have a 2000 XE, 5-Speed with about 230k on it. The original transmission and clutch are still in the vehicle. When the vehicle is running, stationery, in neutral and the clutch pedal is pushed to the floor, the engine and transmission noises are within reason for a vehicle of this age...
  10. Scheduled or Preventive Maintenance
    As I was typing up a thread asking about the availability of replacement electrical connectors for the 1st gen RE4R01A transmission valve body solenoids, it dawned on me that I had amassed a good deal of information that I haven't seen elsewhere and I thought it would make a good thread to help...
  11. Repair Questions
    Like many others I'm sure, my line pressure solenoid finally went out a few weeks back, leading to me dropping the pan and valve body to replace the upper solenoid pack. Even though I knew them to be fragile due to age, in the process I still broke the tabs off two of the (I believe) two-pin...
  12. Repair Questions
    Bought this Xterra a couple of months ago as a father/son camping, fishing and wheeling project. Unfortunately, a problem has cropped up... The transmission has suddenly started making a low, rattley noise at idle followed by a supercharger-esque whine, which increases with RPM's. Thankfully I...
  13. Repair Questions
    I just had my transmission on My 02 Xterra rebuilt after it had lost reverse. Now when I accelerate, it makes these sounds that sound anywhere from a low moan to a high squeal, like I’ve got a dying cat stuck under there. Sound lasts about 1-2 seconds. The mechanic said to drive it for a couple...
  14. Repair Questions
    Does anyone have any pics or can anyone explain how to position the manual valve when reinstalling the valve body on a 1st gen AT? I completely forgot to position it during reinstall last week and ended up switching all my gears to drive 😅. Getting this thing back to a place where I can work on...
  15. Repair Questions
    Hey, I changed all 5 of spark plugs, tempted many times on the 6th. Ran out of time, and daylight: 2 weeks later, successfully changed 6th spark plug, ran fine for about 2 trips to local store, now not wanting to switch gears. It hesitates, tries to go, and then catches. (slings me forward)...
  16. Repair Questions
    I'm rebuilding my transmission and would like some advice on my findings. The only symptom was that my 2004 SC 4x4 (RE4R01A) wouldn't move in reverse. The major problem is that the reverse clutch oil seal on the oil pump cover supply shaft was destroyed. Since pulling it apart, I can see why it...
  17. Repair Questions
    Thanks in advance for your help everyone. I have an 05 Xterra SE 4WD with 200K. Have had no previous transmission issues. The other day I was taking my family up the mountain. After about 20 minutes of driving my X starting getting stuck in second gear. Because I was driving up the...
  18. Repair Questions
    Hi Everyone, My mom is having problems with her 2006 Xterra. Because of COVID-19 I haven't been able to go over there to see for myself so I'm trying to help her diagnose and best as I can. She is describing a weird situation. Reverse works normally, but in drive there is NO power. She is...
  19. General Discussions
    Installing a sending unit for a A/T temp gauge. The instructions say to install the sending unit into the transmission test port, but looks like the X has two of em? Any idea which one would be best for the most accurate reading? FSM diagram: These are technically line pressure test ports...
  20. Repair Questions
    So I just recently purchased an 05, with 106500 on it. It just started not starting in 1st. I've checked the trans fluid, it's nice and red, and doesn't smell. If I turn it off and restart, it starts in 1st, until I stop, and then it starts in 3rd again. Help
1-20 of 79 Results
Top