Nissan XTerra Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 84 Results
  1. Repair Questions
    I have a 2003 Xterra 3.3 4x2 with 187k (one owner). Its recently developed a weird shudder in when in OD -- when get back on the power after lifting the accelerator, I feel it shudder like I just ran over some train tracks. Then it kicks in okay. With the OD button pushed in (no OD) , it...
  2. Modification Questions
    Anyone add a automatic transmission temperature gauge to a first gen 3.3? Looks like the odb2 doesn’t capture that information but may be wrong. Is there a test plug on the 1st generation transmission to plug the sensor into or is the only option inline on the tranny pressure or return line? I’m...
  3. Repair Questions
    I have a 2004 3.3L Non-Supercharged 5-speed Xterra with 220k miles that has a whine that appears to be coming from the engine bay. The whine is a mid-tone whine similar to that of an RC car (or power wheels). It occurs pretty much all the time: with the clutch engaged and disengaged, when the...
  4. Repair Questions
    I ran the self diagnosis on my transmission and it flashed 16 times. My book says engine speed signal. Can anyone point me in the direction as to what to check out? And is there a way to erase the codes without a special scan tool? Thanks
  5. Repair Questions
    I recall I asked this a while ago but for the life of me and this search function I can’t find that post. I know any foreign liquid, namely water and antifreeze, will eat the adhesive on the clutch pack material. I have read and seen others when rebuilding not just replacing the clutch packs...
  6. Repair Questions
    Hello fellow nissan lovers, My fiance's xterra (203xxxmiles) took a dump on us. She's a teacher and needs her ride running. So the issue we have ran into is the truck just wont go. It starts fine. Does its little high idle. Then when we shift into reverse we can feel the transmission catch...
  7. Repair Questions
    I've done hours of research but cannot seem to find the answer I'm looking for :eek: I have a 2005 Xterra that has a trashed tranny. Up to what year are transmissions interchangeable without modifications?
  8. Repair Questions
    How do I find out which tranny I have?
  9. Modification Questions
    Does anybody have any experience with JDM transmission in our trucks?
  10. Repair Questions
    I have an 01 RWD V6 that will not shift into drive until after it's warmed up. It shifts into 1st and 2nd just fine, but it won't shift into drive until warm. I just dropped the pan, drained about 4 to 5 Q, replaced the filter/screen and gasket, and added new ATF (about 3.75Q). I still have...
  11. New Member Introductions
    I don’t know what to do. Whenever it snows and the roads are slippery the engine seems to do a jerky stall every couple Only when raining or snowing or if roads are slippery. 2008 Nissan XTerra HELP
  12. Repair Questions
    So, I need to thank those of you who replied to my previous post here (especially @XT2015). I've been meaning to get in here and post this for a few weeks now, but just haven't gotten the chance until today. Here's a short story: After a while of not getting around to replacing the radiator...
  13. Repair Questions
    I am new to owning as 07Xterra and it is having trouble accelerating for passing and won't let engine go over 4000 rpms and delays shifts till it hits a certain speed and rev. This is only happening when the engine is warmed up and driving 10+ min. On cold start it seems to run great. The engine...
  14. Repair Questions
    I have a 2000 XE, 5-Speed with about 230k on it. The original transmission and clutch are still in the vehicle. When the vehicle is running, stationery, in neutral and the clutch pedal is pushed to the floor, the engine and transmission noises are within reason for a vehicle of this age...
  15. Scheduled or Preventive Maintenance
    As I was typing up a thread asking about the availability of replacement electrical connectors for the 1st gen RE4R01A transmission valve body solenoids, it dawned on me that I had amassed a good deal of information that I haven't seen elsewhere and I thought it would make a good thread to help...
  16. Repair Questions
    Like many others I'm sure, my line pressure solenoid finally went out a few weeks back, leading to me dropping the pan and valve body to replace the upper solenoid pack. Even though I knew them to be fragile due to age, in the process I still broke the tabs off two of the (I believe) two-pin...
  17. Repair Questions
    Bought this Xterra a couple of months ago as a father/son camping, fishing and wheeling project. Unfortunately, a problem has cropped up... The transmission has suddenly started making a low, rattley noise at idle followed by a supercharger-esque whine, which increases with RPM's. Thankfully I...
  18. Repair Questions
    I just had my transmission on My 02 Xterra rebuilt after it had lost reverse. Now when I accelerate, it makes these sounds that sound anywhere from a low moan to a high squeal, like I’ve got a dying cat stuck under there. Sound lasts about 1-2 seconds. The mechanic said to drive it for a couple...
  19. Repair Questions
    Does anyone have any pics or can anyone explain how to position the manual valve when reinstalling the valve body on a 1st gen AT? I completely forgot to position it during reinstall last week and ended up switching all my gears to drive 😅. Getting this thing back to a place where I can work on...
  20. Repair Questions
    Hey, I changed all 5 of spark plugs, tempted many times on the 6th. Ran out of time, and daylight: 2 weeks later, successfully changed 6th spark plug, ran fine for about 2 trips to local store, now not wanting to switch gears. It hesitates, tries to go, and then catches. (slings me forward)...
1-20 of 84 Results
Top