Nissan XTerra Forum banner

throttle

  1. Repair Questions
    I bought a 2010 Xterra SE about a month ago. About a week and a half ago I started it up, after about 10 seconds it shut down. I tried getting it started again and though it was turning over it wasn’t starting up. I had pulled a couple codes from a check engine light a few days prior (p0123...
  2. Repair Questions
    I recently performed some maintenance and a resonator delete on my new/used 2004 Xterra SE/XE V6 3.3L automatic. Now I'm having the following symptoms: - RPMs bounce/rev from 1k to 2k about 3 or 4 times on the initial startup, then settle around 1.5k (seems high) and doesn't drop to 1k until I...
  3. Repair Questions
    I changed my distributor out this week and to get to the bolt I had to remove the throttle sensor. When I put my car into drive or reverse my rpms jump up to 3500 rpms but when driving my rpms won't go past 2000. Car starts fine rpms at about 700.
  4. Repair Questions
    Hello guys! So, I have a manual 06 X OR with 77k. Just got A total clutch overhaul at a tranny shop. When I go to pick it up they tell me there is a issue with the idle and they don't know how to fix it. The code reader was spitting out a code for the IAC. So I bring the X home with plans to...
  5. Repair Questions
    Since my head swap the car has only been let to idle while I've chased down a couple of bugs. At idle everything sounds fine now, but when I finally gave the engine a little gas I get a loud "single-source" tapping (not from multiple sources such as valve clatter) under the ps valve cover. I...
Top