Nissan XTerra Forum banner
rough idle
1-15 of 15 Results
  1. Repair Questions
    Just recently fixed main problem of misfire, that was a headache but today in good heat I got home and watched my revs bounce from 600-1500. I wont forget to mention that on cold start the revs sit at about 2000-2100, and don't go down until I drive it around. This problem is intermittent...
  2. Repair Questions
    Hey folks, Noob mechanic here, learning what I can through my 2002 3.3 130k miles V6 Xterra. Recently changed the idler pulley for the AC belt and changed all the belts. Since then after a long highway drive, park and restart I get varying levels of a rough idle, sometimes a serious rumble when...
  3. Repair Questions
    I bought a 2001 Xterra SE in June and have been repairing things bit by bit like the fuel tank and knock sensor. It's been running well and I have driven it almost 6,000 miles in the past couple months since I have to drive everywhere now for work due to Covid. On a trip from Michigan to GA...
  4. Repair Questions
    A month ago my 08 Xterra S started idling and accelerating very rough. I took it to get a diagnostic and all they told me was that it was misfiring on cylinder one. Which is what I told them when I walked in the door. So I took the $120 advice and replaced the coil and spark plug on cylinder 1...
  5. Repair Questions
    New member (or I forgot my old username) and been searching on what seems to be a common problem. I’ve got an intermittent crank/no spark which has been frustrating. Going through the checks to hunt it down and I’ve run into some issues while doing so. A quick background rundown and the twist...
  6. Repair Questions
    Vehicle ran hot-replaced thermostat, water pump, timing belt. Had leak from back of thermostat housing into water tube, fixed that. Now have rough idle and doesn't want to accelerate at times when driving. Got a P0325 code. Did not have this problem before the overheating. What issues...
  7. Repair Questions
    2001 Xterra - Runs with rough idle and stalling out at stoplights and while coming to a stop. Cranks back up and keeps going after shut off. During the last month we have replaced Knock Sensor, timing belt, replaced plugs and wires and it's on a 2nd new distributor in 4 weeks (changed out...
  8. New Member Introductions
    My 03 Xterra SE (150k miles) has a rough idle and continues to drive rough. I have not accelerated past 40mph but it is consistently rough throughout driving. The Service Engine Soon light flashes, too. But, no code registers when I scan for it. I have taken it to Autozone and Firestone but...
  9. Repair Questions
    So a friend of mine who owns an Xterra as well told me you guys are the number one place to come to for online help. I have a 2001 Nissan Xterra SE. This thing is my baby. It's everything I wanted in a vehicle and I'm literally in love with it and sold on driving an Xterra for as long as I...
  10. Repair Questions
    Hi there and thanks in advance. I've got a 2003 Supercharged, 145k + mileage I'm having rough idles at stops. Shakes the entire car for about 7-10sec, stabalizes for about 10 sec, shakes again, repeat. The RPM needle also jumps around when it's shaking. This happens in P and in Drive...
  11. Repair Questions
    First I would like to thank everyone as I have learned alot reading here and it's been a big help getting me this far. Ok I bought this 01 Xterra has 215K on it and had a blown head gasket. I replaced it all exhaust gaskets, water pump, Timing belt, cap wires and plugs, fuel filter two idler...
  12. Repair Questions
    My '04 xterra has the 2.4 liter 4 cylinder engine. I just replaced my valve cover seal. After putting everything back together and starting the car up I noticed it was making this terrible whistling sound and the rpms were all over the place until after about 30 seconds the car just shut off. It...
  13. Repair Questions
    I have a 2000 Xterra with 135,000 miles, that I absolutely love. It goes everywhere and does everything that I need it too. It has rarely broken down. I try to take good care of it. The day after Hurricane Sandy, I started down my driveway and took the car right back up. [My driveway is about...
  14. Repair Questions
    So I replaced the Ks and CPS b/c the codes were up and engine was running rough. Engine ran good for about half hour then it got warm and started running rough again. So we turned it off, clean MAF sensor and still no joy. Now this morning service engine light is back on this morning. WTF is...
  15. Repair Questions
    Hi everyone, I've got an 05' 4X4 Xterra S and it's been fantastic until today. I was sitting in a parking lot waiting for my family and noticed that the A/C was getting warmer, and I smelled coolant. I popped the hood and noticed coolant coming from the little hose just to the left of the...
1-15 of 15 Results
Top