Nissan XTerra Forum banner
air conditioning
1-10 of 10 Results
  1. Repair Questions
    05 Xterra here. Over the past few weeks my AC has been inconsistent when it comes to working. I've noticed that when I press the AC button, if the light on the AC button doesn't come on, it doesn't get cold. The two buttons next to it, rear defrost and recirculate air, both have lights that...
  2. Repair Questions
    So I bought my first gen x terra an 00 in the winter I didn't worry about the ac so much, and now out here in AZ we are almost reaching 120 degrees outside.... The lady I bought it from said she had something to do with electrical on the ac by everything looks stock and untouched by a shorty...
  3. Repair Questions
    I have an 05 and had the AC issue I have seen others post about where it only functioned on 1 level. I changed the blower motor resistor about a year ago and everything worked out great. Then a few moms ago, I get no air coming out of the vents at all. Sometimes there is a high pitched...
  4. Repair Questions
    Hello, I have a 2001 xterra se, the AC is not getting cold, this happened last summer as well (I live in arizona where AC is a bit crucial) and it was resolved with a recharge. This summer it stopped getting cold again, I recharged it but noticed a leak near the hose that connects to the low...
  5. Repair Questions
    a few days ago, i got a bunch of lights flashing on my dash, and all the electrical shut down. took it into the school shop to find out that the A/C hose leaked all over the alternator. im trying to track down a replacement hose, but im not sure if i need the discharge, or suction line. any help...
  6. Repair Questions
    I just punctured something... What is it!? When it first happened I thought it was my radiator but upon further investigation i noticed my radiator is behind this thing. After I put a hole in it it started to leak air and it smelled kind of like Freon so im thinking it has something to do with...
  7. Repair Questions
    I have a 04 SE with 135k miles on it. Yesterday, I was driving around all day and stopped for a while and the car was idling. I noticed all of a sudden that the air conditioning stopped working and then checked the temp gauge. It was red lined. I parked it there and left it for several...
  8. Repair Questions
    I've had a small leak somewhere in the line for a while now. I recharged the system and it worked for about 3 months...then I recharged it again, and it only lasted 2 weeks. Now I can visually see it leaking, and have noticed where the leak is. It appears to be the hose that attaches to the...
  9. Repair Questions
    I am having a problem with my 05 xterra a/c. This problem exists both on the a/c and defrost . On low speed the a/c light is on but the blower motor is not spinning at all. On all 3 of the other speeds the a/c light shuts off but the blower motors operates correctly. I've read all the other...
  10. Repair Questions
    I have a leak in the a/c system. I have traced it down to the high pressure hose between the condenser and the compressor. The leak is where the metal tube is crimped on to the rubber hose. First of all, I was wondering if there is a cheap and effective way to repair the hose. If not, I can...
1-10 of 10 Results
Top