Squealing noise from front during cold weather and left turns - Nissan Xterra Forum
 
Thread Tools Display Modes
post #1 of 3 Old 01-07-2013, 03:17 PM Thread Starter
martinqc
Noob
 
Join Date: Jan 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
martinqc is on a distinguished road
Question Squealing noise from front during cold weather and left turns

Hello all, once again. I remembered another problem I need to fix and wanted to bounce it off of you all to get some direction. I have seen other threads that mention squealing like mine, but there always seems to be an improtant difference between my issue and theirs. So I figured I'd post mine and see what comes up.

My car squeals from the front when going over bumps and also during left turns. The squealing is worse in colder weather and almost non-existent during warm weather. It has progressively gotten worse over time. I'm not sure where to even start and hope I might find some ideas here. It is important that the squealing does not change at all with air conditioning or anything else. Only teperature, turning left, and bumpy roads make it squeal. Hope to hear something soon and appreciate all your help.
martinqc is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-07-2013, 03:40 PM
Chef
Seasoned
 
Chef's Avatar
 
Join Date: Dec 2011
Posts: 100
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2003 Xterra
Chef is on a distinguished road
Add power steering fluid
Chef is offline  
2003 Xterra
post #3 of 3 Old 01-07-2013, 05:24 PM Thread Starter
martinqc
Noob
 
Join Date: Jan 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
martinqc is on a distinguished road
I have checked the fluid levels and it is where it should be. I know that adding fluid over the max limit is not a good thing, so not sure if this is the right thing to do. Simple turning does not make a squeal. If I sit in my driveway and turn, there is no squealing.
martinqc is offline  
Reply

Tags
bumpy , cold , squeal , turn

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off