02 Sensor part number Front Left, Upstream - Nissan Xterra Forum
Reply
 
Thread Tools Display Modes
#1 Old 12-26-2012, 09:53 AM
PlayerZer0
Member
 
PlayerZer0's Avatar
 
Join Date: Jan 2012
Location: Kaneohe Bay, Hawaii
Posts: 30
2004 Xterra
PlayerZer0 is on a distinguished road
02 Sensor part number Front Left, Upstream

Ok,

does anyone have a part number for the upstream-left O2 sensor ? I have purchased the NTK 24805, and the Bosch 18002. and Neither of the Threads are correct on it. As if right now, we have replaced all the O2 sensors on the leftside, just to be logical, and the next step for me, is to just replace the entire CAT.

Oh BTW, Happy Holidays and I am glad to be back statside!

Now if i can just get rid of this CEL..... which is throwing the infamous p0430 code.

( •_•), ( •_•) + <⌐■-■ = (⌐■_■)
I wear my sunglasses at night
PlayerZer0 is offline  
2004 Xterra
Sponsored Links
Advertisement
 
#2 Old 12-26-2012, 11:26 AM
RacerXXL
Administrator
 
RacerXXL's Avatar
 
Join Date: Apr 2009
Location: Northern Alabama
Posts: 7,328
2000 XE V6 Xterra
RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all
Garage
Is the problem that the replacements are a totally different size then the original? If so you probably have the correct one but the upstream O2 sensors are actually threaded into an adapter. Problem is the adapter tends to be frozen to the O2 sensor.

This is from a write up I did on installing headers but it should help. Just remove the adapter from the old O2 sensor and transfer to the new one.
Quote:
Take the cat to your work bench and using a 22mm wrench remove the O2 sensor. Unlike the down tubes you will notice that the sensor is not threaded directly into the cat bung but is instead threaded into an adapter. On mine the sensor was frozen in the adapter and both came out together. Simply place the O2 sensor adapter in a vice, tighten the jaws on two flats, and remove the O2 sensor from adapter.




-Kelly- Build Thread

Then he showed those men of will what will really was. - Verbal Kint
RacerXXL is offline  
2000 XE V6 Xterra
#3 Old 12-26-2012, 05:20 PM
PlayerZer0
Member
 
PlayerZer0's Avatar
 
Join Date: Jan 2012
Location: Kaneohe Bay, Hawaii
Posts: 30
2004 Xterra
PlayerZer0 is on a distinguished road
YEAAAAAAAAAAAAAAAAAAAAAAAH <---- did a dummy thing. the entire nut/flange thingy came off when we took off the old O2 sensor. i noticed it right when i was looking at it today, so we just took it apart and got it all fitted in now.

( •_•), ( •_•) + <⌐■-■ = (⌐■_■)
I wear my sunglasses at night
PlayerZer0 is offline  
2004 Xterra
#4 Old 12-26-2012, 05:21 PM
PlayerZer0
Member
 
PlayerZer0's Avatar
 
Join Date: Jan 2012
Location: Kaneohe Bay, Hawaii
Posts: 30
2004 Xterra
PlayerZer0 is on a distinguished road
Unfortunately, it didnt fix the problem. Next step is to replace the cat-convetor, which is what i believe, phrog man did

( •_•), ( •_•) + <⌐■-■ = (⌐■_■)
I wear my sunglasses at night
PlayerZer0 is offline  
2004 Xterra
#5 Old 12-26-2012, 09:38 PM
xtacular
Spaz
 
xtacular's Avatar
 
Join Date: May 2010
Location: Washington
Posts: 5,399
2002 Xterra
xtacular is a jewel in the rough xtacular is a jewel in the rough xtacular is a jewel in the rough xtacular is a jewel in the rough
Did you reset the light? It won't go out very quickly after fixing the problem.

2002 Super Black 5 Speed 4x4
Lift/Suspension: AC Shackles and UCAs, Extended Bilsteins, 2" BL
Armor: front ARB Bumper, rear Skid Row bumper with custom tire carrier
Steering: Bandit 4x4 idler arm bushings, AC HD TRAs, Calmini IAB; Moog TREs and 555 centerlink
Wheels/Tires: 33x12.5x15 Goodyear Duratracs, desert runner wheels
Performance: K&N intake, Doug Thorley headers, Magnaflow muffler
Electronics: backup camera, Pioneer head unit, JBL 770w amp, JL Audio 12" W0, rear Sony Xplods
xtacular is offline  
2002 Xterra
#6 Old 12-27-2012, 07:43 AM
PlayerZer0
Member
 
PlayerZer0's Avatar
 
Join Date: Jan 2012
Location: Kaneohe Bay, Hawaii
Posts: 30
2004 Xterra
PlayerZer0 is on a distinguished road
Well, i unhooked the battery for about 15 minutes to reset the computer, but it still didnt go away. im goign to be taking it to advanced auto today to get the computer reset

( •_•), ( •_•) + <⌐■-■ = (⌐■_■)
I wear my sunglasses at night
PlayerZer0 is offline  
2004 Xterra
#7 Old 12-27-2012, 08:48 AM
intender
Phreak
 
intender's Avatar
 
Join Date: Jan 2012
Location: Yadkin County, NC
Posts: 1,136
2000 SE Xterra
intender will become famous soon enough
Garage
they wont do it more than likely. they might let you take the scanner and do it, but some stores wont do that either. not sure if they let rent their scanners or not, but if they do that will probably be your best option.

Apply dirt liberally, rinse and repeat


<<<-click for build
intender is offline  
2000 SE Xterra
#8 Old 12-27-2012, 10:28 AM
kms1990
Addict
 
kms1990's Avatar
 
Join Date: Jul 2012
Location: benbrook tx
Posts: 643
2000 Xterra
kms1990 is on a distinguished road
autozone should erase it for you or leave it unhooked for more than an hour to reset. which codes did you have?

MY BRIGHT AZZ LIGHTS!

MY STEREO BEATS EM ALL!
My Laundry List
LIFT()
MUD TIRES()
DROP IN K&N FILTER(X)
UPGRADE STEREO(X)
RESTORE BUMPERS(X)
HID AND PIAA FOGS(X)
FIX UP HEADLINER()
WINCH()
MUFFLER UPGRADE()
kms1990 is offline  
2000 Xterra
#9 Old 12-27-2012, 11:56 AM
PlayerZer0
Member
 
PlayerZer0's Avatar
 
Join Date: Jan 2012
Location: Kaneohe Bay, Hawaii
Posts: 30
2004 Xterra
PlayerZer0 is on a distinguished road
I took her to advanced auto, and they did it for me this morning, i just got back from driving about 70 miles. Hasnt thrown a code yet.....

( •_•), ( •_•) + <⌐■-■ = (⌐■_■)
I wear my sunglasses at night
PlayerZer0 is offline  
2004 Xterra
#10 Old 12-27-2012, 11:58 AM
PlayerZer0
Member
 
PlayerZer0's Avatar
 
Join Date: Jan 2012
Location: Kaneohe Bay, Hawaii
Posts: 30
2004 Xterra
PlayerZer0 is on a distinguished road
Sorry, it was the P0430 code

( •_•), ( •_•) + <⌐■-■ = (⌐■_■)
I wear my sunglasses at night
PlayerZer0 is offline  
2004 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off