too much oil clatter - Nissan Xterra Forum
 
Thread Tools Display Modes
post #1 of 5 Old 12-10-2012, 10:25 AM Thread Starter
dymond
Member
 
Join Date: Oct 2012
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2004 Xterra
dymond is on a distinguished road
too much oil clatter

heres a heads up I just received. 1st gen 6 cyl only take 3.5 quarts oil. I had 5 in mine. the pressure (im guessing) gave me terrible metalic chatter Ive been trying to remedy. drained 1.5 quarts and chatter all but disappeared. snds way better, and i wont blow up my motor! hopefully this fixes my chatter completely . Ill see over a day or so. hope i didnt damage anything. only ran truck one day with 5 qrts.
dymond is offline  
2004 Xterra
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-11-2012, 08:32 AM
SamsXE
Veteran
 
SamsXE's Avatar
 
Join Date: Apr 2012
Location: Columbus, Ohio
Posts: 308
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2004 Xterra
SamsXE is on a distinguished road
You should be alright. Read the manual next time! Dont feel bad I put regular PS fluid in my honda once and it foamed out of the res. all over my garage floor (you need special honda fluid)...my old man was not pleased.

Make sure you keep up with the fluids over the life of the truck and it will last forever! (almost)
SamsXE is offline  
2004 Xterra
post #3 of 5 Old 01-10-2013, 02:37 PM
bplo
Noob
 
Join Date: Nov 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2002 Xterra
bplo is on a distinguished road
Had same chatter with mine after a shop did full timing belt job... Finally checked oil level after 1000 miles or so and saw they over filled it by 1.5 quarts. The one thing I didn't double check once I got it back from them, figures.
bplo is offline  
2002 Xterra
post #4 of 5 Old 01-10-2013, 04:00 PM Thread Starter
dymond
Member
 
Join Date: Oct 2012
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2004 Xterra
dymond is on a distinguished road
after i reduced my oil appropriately it ran better but the noise was still there. turns out it was a vacuum leak under the place where egr valve is. sounds great now. When car is cold however it cuts off from time to time at stops. not sure what it is. Its been triple seafoamed, new fuel filter, air breather mod and maf cleanse. dont know..
dymond is offline  
2004 Xterra
post #5 of 5 Old 01-10-2013, 04:17 PM
ShiftingSkys
Phreak
 
ShiftingSkys's Avatar
 
Join Date: Aug 2010
Location: Raleigh
Posts: 1,751
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2002 Xterra
ShiftingSkys will become famous soon enough
Yeah Many shops that work on the X put like 5 qts in them and I have no idea why. they only take 3.5~. Hopefully you did not blow your rear main seal.

2002 Nissan Xterra

Lifted and Ready to Roll!

Build Thread-http://www.clubxterra.org/forums/showthread.php?t=38877
ShiftingSkys is offline  
2002 Xterra
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off