Engine Codes P1143,P0134,P0328 - Nissan Xterra Forum
Reply
 
Thread Tools Display Modes
#1 Old 11-29-2012, 10:04 PM
kdog125
Member
 
Join Date: Nov 2011
Location: New York
Posts: 38
2002 Xterra
kdog125 is on a distinguished road
Engine Codes P1143,P0134,P0328

Hey everyone, I just got checked out at autozone and they ran these codes for a CEL on. Light has been on a few weeks. Also came on a few months ago but didnt last too long. He cleared the codes and will see if it comes back. Need inspection done ASAP. Anyone have any info on these codes? I read on the knock sensor code and seems like i should just ignore it. I have a 2002 SE 4x4 not SC. Truck seems to be running perfectly fine. No knocking sounds at all, consistent oil changes every 3k miles. Truck has like 138k miles on it. No rough idling or anything. Does anyone have any info on the other codes? I believe they are o2 sensors? Thank a lot.
kdog125 is offline  
2002 Xterra
Sponsored Links
Advertisement
 
#2 Old 11-29-2012, 10:13 PM
RacerXXL
Administrator
 
RacerXXL's Avatar
 
Join Date: Apr 2009
Location: Northern Alabama
Posts: 7,314
2000 XE V6 Xterra
RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all
Garage
All the codes can be found in the EC (engine control) section of the factory service manual. Search for each individual code and it will show you the possible causes and how to diagnose the problem.

-Kelly- Build Thread

Then he showed those men of will what will really was. - Verbal Kint
RacerXXL is offline  
2000 XE V6 Xterra
#3 Old 11-30-2012, 07:53 AM
ShiftingSkys
Phreak
 
ShiftingSkys's Avatar
 
Join Date: Aug 2010
Location: Raleigh
Posts: 1,751
2002 Xterra
ShiftingSkys will become famous soon enough
Possible causes of the code P1143
- Faulty Front Heated Oxygen Sensor Bank 1
- Intake air leaks
- Front Heated Oxygen Sensor Bank 1 harness is open or shorted
- Front Heated Oxygen Sensor Bank 1 circuit poor electrical connection
- Fuel pressure
- Injectors

If there are no intake air leaks, the most likely cause of the P1143 code is the front O2 sensor bank 1.

P0134
Replacing the O2 Sensor 1 usually takes care of the problem
Help with this
When is the code detected?
The voltage from the sensor is constantly approx. 0.3V

The third is Knock sensor. I would just leave that alone. More often than not with that code replacing that sensor fixes it.

OBD-ll Codes.com

2002 Nissan Xterra

Lifted and Ready to Roll!

Build Thread-http://www.clubxterra.org/forums/showthread.php?t=38877
ShiftingSkys is offline  
2002 Xterra
#4 Old 11-30-2012, 01:23 PM
kdog125
Member
 
Join Date: Nov 2011
Location: New York
Posts: 38
2002 Xterra
kdog125 is on a distinguished road
Thanks for the info. Just wanna make sure, the oxygen sensor one is on the passenger side, highest up and can be seen easily seem? Wasn't able to upload a picture sorry
kdog125 is offline  
2002 Xterra
#5 Old 11-30-2012, 01:52 PM
muadeeb
Banned
 
Join Date: Oct 2011
Location: Dallas, Tx
Posts: 642
2001 Xterra
muadeeb will become famous soon enough
Yep, that's Bank 1, Sensor 1. When you pull it, the bung may come out of the exhaust too.
muadeeb is offline  
2001 Xterra
#6 Old 11-30-2012, 02:42 PM
kdog125
Member
 
Join Date: Nov 2011
Location: New York
Posts: 38
2002 Xterra
kdog125 is on a distinguished road
Don't I need that bung to come out so I can put the new sensor into that bung and I put that whole piece (sensor and bung) back into its original spot? Thanks again for all the help
kdog125 is offline  
2002 Xterra
#7 Old 11-30-2012, 03:09 PM
muadeeb
Banned
 
Join Date: Oct 2011
Location: Dallas, Tx
Posts: 642
2001 Xterra
muadeeb will become famous soon enough
Both are threaded, so if it stays in, great. If it comes out, fine.
muadeeb is offline  
2001 Xterra
#8 Old 11-30-2012, 10:49 PM
kdog125
Member
 
Join Date: Nov 2011
Location: New York
Posts: 38
2002 Xterra
kdog125 is on a distinguished road
Hey guys. I picked up the oxygen sensor (part #13420). I'm just confused on the location of this sensor under the hood. It's the oxygen sensor 1, bank 1 that needs to be changed. I've read its the one located on the passenger side of the engine bay and lays on top of the exhaust manifold I believe (pics attached) and be easily worked upon. However in the diagram attached, it seems like sensor one bank one is on the opposite side (driver side). Any clarity would be very appreciated.
Attached Thumbnails
Click image for larger version

Name:	pic1.JPG
Views:	140
Size:	36.1 KB
ID:	9183   Click image for larger version

Name:	pic2.JPG
Views:	136
Size:	142.7 KB
ID:	9184   Click image for larger version

Name:	pic3.GIF
Views:	621
Size:	45.0 KB
ID:	9185   Click image for larger version

Name:	pic4.JPG
Views:	93
Size:	12.9 KB
ID:	9186  

Last edited by kdog125; 11-30-2012 at 10:54 PM.
kdog125 is offline  
2002 Xterra
#9 Old 11-30-2012, 11:05 PM
RacerXXL
Administrator
 
RacerXXL's Avatar
 
Join Date: Apr 2009
Location: Northern Alabama
Posts: 7,314
2000 XE V6 Xterra
RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all
Garage
The view in that diagram you have is from the rear, flywheel end, of the engine so it is on the PS. Should be the one that is screwed into the Cat.

Have you run through the diagnostic to find what is causing the code?

-Kelly- Build Thread

Then he showed those men of will what will really was. - Verbal Kint
RacerXXL is offline  
2000 XE V6 Xterra
#10 Old 11-30-2012, 11:18 PM
kdog125
Member
 
Join Date: Nov 2011
Location: New York
Posts: 38
2002 Xterra
kdog125 is on a distinguished road
Hmm i'm still confused by what you said. I just got those codes when I got it read at autozone b/c my CEL was lit for a few weeks. I've noticed excessive exhaust smoke and definitely have noticed high fuel consumption. So i figured i would replace sensor one bank one and hope that takes care of the problem/CEL light from coming back on...So is the picture I took of the sensor the correct sensor to be changed? sensor one bank one?
kdog125 is offline  
2002 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off