xterra04red - Nissan Xterra Forum
 
Thread Tools Display Modes
#1 Old 11-27-2012, 09:21 AM
xterra04red
Noob
 
Join Date: Nov 2012
Posts: 1
2004 Xterra
xterra04red is on a distinguished road
xterra04red

hey im new on here and i love xterras this is my second one. i have owned my current one a little over a year. and when ever i apply the brakes hard or at a slight decline or incline i smell this burning smell and a little bit of smoke comes from the hood. i thought it might be a clogged heater but it smells more like burning then a sweet smell and ir only really smells when the brakes are applied. what is it and how do i fix it. thanks for all ur help
xterra04red is offline  
2004 Xterra
Sponsored Links
Advertisement
 
#2 Old 11-27-2012, 09:52 AM
muadeeb
Banned
 
Join Date: Oct 2011
Location: Dallas, Tx
Posts: 642
2001 Xterra
muadeeb will become famous soon enough
New rotors?
muadeeb is offline  
2001 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off