dash lights and back lights keep blowing fuses - Nissan Xterra Forum
Reply
 
Thread Tools Display Modes
#1 Old 02-20-2011, 04:38 PM
crmarie
Noob
 
Join Date: Feb 2011
Posts: 5
2004 Xterra
crmarie is on a distinguished road
dash lights and back lights keep blowing fuses

does anyone know how to fix this problem? all the system check lights work just the back lights and the running lights dont turn on. if anyone can help id love you forever!
crmarie is offline  
2004 Xterra
Sponsored Links
Advertisement
 
#2 Old 02-20-2011, 05:33 PM
NUKEhead
Addict
 
NUKEhead's Avatar
 
Join Date: Mar 2010
Location: Long Island/Albany, NY
Posts: 754
2002 S/C Xterra
NUKEhead is on a distinguished road
I'm having the same EXACT problem, I'm not sure what's causing it, I have my dash apart re-doing my wiring trying to find a short somewhere. For me the first time it happened was almost exact with me turning my heat off.


Do you have any aftermarket electronics?
NUKEhead is offline  
2002 S/C Xterra
#3 Old 02-20-2011, 06:21 PM
crmarie
Noob
 
Join Date: Feb 2011
Posts: 5
2004 Xterra
crmarie is on a distinguished road
Just a radio other then that no. It happened right after I replaces the battery. When I turn the lights on it blows a fuse.
crmarie is offline  
2004 Xterra
#4 Old 02-20-2011, 06:31 PM
morpheus
Veteran
 
Join Date: Jun 2010
Location: Milton, Ontario
Posts: 264
2003 Xterra
morpheus is on a distinguished road
Check your fuses. If it keeps blowing fuses, if you have trailer wiring, check for corrosion in the connector.

Mike Thomson
Service Manager
Milton Nissan
www.miltonnissan.ca

morpheus is offline  
2003 Xterra
#5 Old 02-20-2011, 07:25 PM
miskywhisky
Phreak
 
Join Date: Sep 2009
Location: OR
Posts: 1,833
2000 Xterra
miskywhisky will become famous soon enough miskywhisky will become famous soon enough
Quote:
Originally Posted by morpheus View Post
Check your fuses. If it keeps blowing fuses, if you have trailer wiring, check for corrosion in the connector.
this!! I had the problem with a trailer one time, turned out to be a wire shorting out on the trailer. Good thing headlights are separate and i had my gps. Made it home with the hazards on.
miskywhisky is offline  
2000 Xterra
#6 Old 02-20-2011, 09:08 PM
Lucky13
Veteran
 
Lucky13's Avatar
 
Join Date: Nov 2010
Location: Poinciana, FL
Posts: 440
2000 Xterra
Lucky13 is on a distinguished road
Quote:
Originally Posted by miskywhisky View Post
this!! I had the problem with a trailer one time, turned out to be a wire shorting out on the trailer. Good thing headlights are separate and i had my gps. Made it home with the hazards on.
thats why you should carry a headlamp in the truck :P
Lucky13 is offline  
2000 Xterra
#7 Old 02-20-2011, 09:11 PM
NUKEhead
Addict
 
NUKEhead's Avatar
 
Join Date: Mar 2010
Location: Long Island/Albany, NY
Posts: 754
2002 S/C Xterra
NUKEhead is on a distinguished road
Quote:
Originally Posted by miskywhisky View Post
this!! I had the problem with a trailer one time, turned out to be a wire shorting out on the trailer. Good thing headlights are separate and i had my gps. Made it home with the hazards on.

And how do you deal with a corroded connector?

Anyway besides replacing it?
NUKEhead is offline  
2002 S/C Xterra
#8 Old 02-21-2011, 08:34 AM
maxximus1210
Noob
 
Join Date: Dec 2008
Posts: 5
2002 Xterra
maxximus1210 is on a distinguished road
Had the same problem with my 02 se/sc, there is a tech service bulletin about this issue, If you remove the right and left front marker lites and follow the wires they rub against the chassis and short out. hope this helps...=)
maxximus1210 is offline  
2002 Xterra
#9 Old 02-21-2011, 02:12 PM
crmarie
Noob
 
Join Date: Feb 2011
Posts: 5
2004 Xterra
crmarie is on a distinguished road
Thanks I'll try that. Hopefully it works.
crmarie is offline  
2004 Xterra
#10 Old 02-26-2011, 12:18 AM
kizzolie
Addict
 
kizzolie's Avatar
 
Join Date: Mar 2010
Location: Swampscott, MA
Posts: 592
2002 XE Xterra
kizzolie is on a distinguished road
mine just started doing the same thing...any word on a fix? im gonna rip it apart tomorrow

-Kyyle

-=In Kizzolie We Trust=-

]
-Mr. President.
My Build Thread.
kizzolie is offline  
2002 XE Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off