Know issue, no luck! Heater blowing cold air... - Nissan Xterra Forum
 
Thread Tools Display Modes
post #1 of 10 Old 12-19-2010, 11:24 PM Thread Starter
aliengin
Noob
 
Join Date: Dec 2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
aliengin is on a distinguished road
Know issue, no luck! Heater blowing cold air...

OK, before anyone says anything I did my search and found a lot of posts on the web with the same problem. Answer seems to be the cooler!
Its a 08 Xterra Off Road
Here is my problem:
Heater blows cool air not like AC but more like fan air when the car is not moving. You can feel it even when stopping at red lights. Once the car starts moving heat turns on. Also when the car is moving I can smell the fume like almost the heat is coming from engine department without any filtration, this happens even if I select circulate cabin air button.
Cooler was at the minimum level in the small reservour.
This is what i did:
I filled the reservoir to max level, and topped the radiator. Put the car on a ramp lifting front end, open the valve and run the engine for 15 minutes about 2000 rpms. I also turn the heat all the way up. After the process topped the radiator and filled the reservoir again to max. Drove for 20 minutes and problem still existed.
Second solution took the car to dealer and told them the problem. They said they didn't have the mechanic on Saturday but they told me they checked the pressure level in the rediator and couldn't find any problems.
Car does not over heat but again I am in Chicago and its around 15s! I checked the cooler again today and seems like it lost some since Friday. Level was a litle under Minimum level.
Its obvious that its loosing from somewhere and heater is sucking air from engine compartment. One other thing is when i turn the engine off if the heat is on I can hear some water bubling right behind the dashboard.
I am going to take the car to another service this week. Does anyone know what this could be?
Thanks.
aliengin is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 12-20-2010, 12:59 AM
ASTE25
Member
 
ASTE25's Avatar
 
Join Date: Dec 2010
Location: New Market, Alabama
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2011 S 4X4 Xterra
ASTE25 is on a distinguished road
I thought we cleared this up. lol.
ASTE25 is offline  
2011 S 4X4 Xterra
post #3 of 10 Old 12-20-2010, 08:45 AM Thread Starter
aliengin
Noob
 
Join Date: Dec 2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
aliengin is on a distinguished road
I know I know. I am just trying to get more feedback about this, maybe someone had the same problem. My only concern is I am going to leave the truck at the dealer and they are going to turn the heater on IN THE HEATED SERVICE AREA (which they did on Saturday) and tell me nothings wrong with it.
BTW, I checked the floor this morning and there was no neak overnight. I drove about 10 miles and i will check the reservoir tonoght to see the fluid level.
aliengin is offline  
post #4 of 10 Old 12-20-2010, 09:56 AM
S2X01
Phreak
 
S2X01's Avatar
 
Join Date: Nov 2008
Location: Wheat Ridge, CO
Posts: 1,309
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2001 Xterra
S2X01 will become famous soon enough
thermostat?


Stu.

'01 Silver XE
Got Some Mods.....More comin.

BUILD THREAD

http://www.clubxterra.org/forums/showthread.php?t=16390

Quote:
Originally Posted by Cyclemut View Post
That's it, I'm gonna start carrying my muzzle-loader in the rig. Ain't no sneakin' up on me!

Of course there's always been a rivalry between Blackfoot and the Shoshone tribes anyway. Indian signs getting thrown around and my wife looking at me like I'm the idiot. I mean really, someone flashes me 'Your mom looks like a doe's ass' sign and it's on!
S2X01 is offline  
2001 Xterra
post #5 of 10 Old 12-20-2010, 01:16 PM
ASTE25
Member
 
ASTE25's Avatar
 
Join Date: Dec 2010
Location: New Market, Alabama
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2011 S 4X4 Xterra
ASTE25 is on a distinguished road
It won't matter if they turn it on in their heated shop. All that matters is that the heat is on and the water is allowed to flow through the heater core to purge the air. Even in the shop the heater when working correctly should be a lot hotter than the ambient air in the shop. Let me know what you find out.
ASTE25 is offline  
2011 S 4X4 Xterra
post #6 of 10 Old 12-20-2010, 01:24 PM
Itsme
Phreak
 
Itsme's Avatar
 
Join Date: Sep 2010
Location: Oregon
Posts: 3,111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2000 4x4 Xterra
Itsme will become famous soon enough Itsme will become famous soon enough
just some thoughts:
It could be the heater core is leaking and needs to be replaced. This could cause the engine compartment smell you talked about. It could also just be a heater hose leaking on the firewall and getting into the heater.
The fact that it is cold at while stopped and at idle, could be to air in the system, filling the heater core with air and not coolant.
Itsme
Itsme is offline  
2000 4x4 Xterra
post #7 of 10 Old 12-20-2010, 11:06 PM
ASTE25
Member
 
ASTE25's Avatar
 
Join Date: Dec 2010
Location: New Market, Alabama
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2011 S 4X4 Xterra
ASTE25 is on a distinguished road
Good point about the smell. He mentioned it, but said it smelled like engine fumes. I could see now how someone might describe the smell of coolant like that.
ASTE25 is offline  
2011 S 4X4 Xterra
post #8 of 10 Old 12-22-2010, 12:01 PM
ASTE25
Member
 
ASTE25's Avatar
 
Join Date: Dec 2010
Location: New Market, Alabama
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2011 S 4X4 Xterra
ASTE25 is on a distinguished road
Well, what was the verdict? Did you take it in yet?
ASTE25 is offline  
2011 S 4X4 Xterra
post #9 of 10 Old 12-22-2010, 12:29 PM
BakerX05
Seasoned
 
BakerX05's Avatar
 
Join Date: Mar 2010
Location: Oregon City, OR
Posts: 217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2005 Xterra
BakerX05 is on a distinguished road
try this

http://www.thenewx.org/forum/showthread.php?t=24370

Baker
'05 Granite SE 4x4|AJ SS Rock Slider|PRG 3" suspension lift|285/75r16 Yokohama Geolander MT+|Pro Comp 7089-6868|PIAA 520 ATP|Shrock rear bumper w/tire carrier|NXrocks Skids|IMS|Flip Kit| Baker's X
BakerX05 is offline  
2005 Xterra
post #10 of 10 Old 01-11-2011, 05:43 PM
jacarpenter
Noob
 
Join Date: Jan 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2005 Xterra
jacarpenter is on a distinguished road
I have an 05 and its doing the exact same thing. Did you find out what the problem was. I really dont want to spend tons on money at the dealer when it is probably a simple fix.
jacarpenter is offline  
2005 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off